aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-24 02:00:01 +0200
commitf081f5691ec9bc12de544735073f561969c89708 (patch)
treeda087e5553befc93acd09b2689ecf61f6a3c2886 /gnu/packages/disk.scm
parent8fc748d054ee1370a4b7856abb672d4ceb3044d1 (diff)
downloadguix-f081f5691ec9bc12de544735073f561969c89708.tar
guix-f081f5691ec9bc12de544735073f561969c89708.tar.gz
gnu: duc: Run tests.
* gnu/packages/disk.scm (duc)[arguments]: Replace the 'check phase to run tests.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 4587b558d2..69c02347c3 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1383,7 +1383,19 @@ reliably with @code{bmaptool} than with traditional tools, like @code{dd} or
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/" ,name "-" ,version)))
- (copy-recursively "examples" (string-append doc "/examples"))))))))
+ (copy-recursively "examples" (string-append doc "/examples")))))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (substitute* "test.sh"
+ ;; Keep the test logs where --keep-failed can see them.
+ (("^(DUC_TEST_DIR=).*" _ assign)
+ (format #f "~a~a/test-directory~%" assign (getcwd)))
+ ;; XXX ‘actual size’ differed on my system (a consistent 348160
+ ;; bytes where the tests expect 540672). However, the ‘apparent
+ ;; size’ matches, as does the actual test output. Good enough…?
+ ((" [0-9]*B actual") " [0-9]*B actual"))
+ (when tests?
+ (invoke "./test.sh"))))))) ; no ‘check’ target
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs