aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-12-28 23:58:59 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-12-29 19:48:16 +0100
commit2c371d2cd9a30bf88fe9aae53913526876b01bcc (patch)
tree9a7ce60ca98259b47de889b8b8bca424b8c76dc8 /gnu/packages/disk.scm
parentc5c28df899b4c4f114bee9afd58dbde9fbbf3424 (diff)
downloadguix-2c371d2cd9a30bf88fe9aae53913526876b01bcc.tar
guix-2c371d2cd9a30bf88fe9aae53913526876b01bcc.tar.gz
gnu: f3: Fix cross-compiling.
* gnu/packages/disk.scm (f3) [arguments]: Use Gexp. Change-Id: I906a2b7b7691ae53592cfa35ba64fc7e7d735664 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 754c70897c..165f0a8a74 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -843,18 +844,18 @@ systems. Output format is completely customizable.")
(base32 "17l5vspfcgfbkqg7bakp3gql29yb05gzawm8n3im30ilzdr53678"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no check target
- #:make-flags (list (string-append "CC=" ,(cc-for-target))
- (string-append "PREFIX=" %output))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-after 'build 'build-extra
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "extra" make-flags)))
- (add-after 'build 'install-extra
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "install-extra" make-flags))))))
+ (list #:tests? #f ; no check target
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure script
+ (add-after 'build 'build-extra
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "extra" make-flags)))
+ (add-after 'build 'install-extra
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "install-extra" make-flags))))))
(inputs
(list eudev parted))
(home-page "http://oss.digirati.com.br/f3/")