aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-02 15:01:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-02 15:03:00 +0100
commit840d5439395a6e48bad0f0ebec3e4be62998da0d (patch)
tree4bdb8198ef9eb0c4ee75fc60326d3aa9c6568149 /gnu/packages/digest.scm
parent4781f0458de7419606b71bdf0fe56bca83ace910 (diff)
downloadguix-840d5439395a6e48bad0f0ebec3e4be62998da0d.tar
guix-840d5439395a6e48bad0f0ebec3e4be62998da0d.tar.gz
gnu: python-xxhash: Update to 3.1.0.
* gnu/packages/digest.scm (python-xxhash): Update to 3.1.0. [build-system]: Use pyproject-build-system. [native-inputs]: Add python-setuptools-scm.
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 4211848fdb..481771804b 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Ryan Prior <rprior@protonmail.com>
-;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,9 +25,11 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (guix utils)
+ #:use-module (gnu packages python-build)
#:use-module (ice-9 match))
(define-public wyhash
@@ -111,15 +113,17 @@ platforms (both big and little endian).")
(define-public python-xxhash
(package
(name "python-xxhash")
- (version "2.0.2")
+ (version "3.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xxhash" version))
(sha256
(base32
- "0jbvz19acznq00544gcsjg05fkvrmwbnwdfgrvwss3i1ys6avgmp"))))
- (build-system python-build-system)
+ "1hdxcscry59gh0znlm71ya23mm9rfmvz8lvvlplzxzf63pib28dc"))))
+ (build-system pyproject-build-system)
+ ;; Needed to embed the correct version string
+ (native-inputs (list python-setuptools-scm))
(home-page "https://github.com/ifduyue/python-xxhash")
(synopsis "Python binding for xxHash")
(description "This package provides Python bindings for the xxHash hash