aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-15 19:43:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-16 16:27:03 +0100
commit12e9687eb925eff12200f86c479344261203a464 (patch)
tree2a378e32a8096f9646949c16df0b531143d2e5b8 /gnu/packages/debian.scm
parentd83cc1e7d25b92559cabcc0777fb62baa52cb921 (diff)
downloadguix-12e9687eb925eff12200f86c479344261203a464.tar
guix-12e9687eb925eff12200f86c479344261203a464.tar.gz
gnu: dpkg: Update to 1.21.0.
* gnu/packages/debian.scm (dpkg): Update to 1.21.0. [arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index b01ef87945..b2bd6c411e 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -335,7 +335,7 @@ other apt sources typically provided by open source developers.")
(define-public dpkg
(package
(name "dpkg")
- (version "1.20.9")
+ (version "1.21.0")
(source
(origin
(method git-fetch)
@@ -344,8 +344,7 @@ other apt sources typically provided by open source developers.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "16wlb8hwbdvxar187bjd4pzdzj95g3l2ryi2khqqmwbyca4sjm1n"))))
+ (base32 "0g33cyd0qbyfdrphcw8m8ikj2hxqpjbyxbhvnp751515c8hgc4rx"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -354,8 +353,7 @@ other apt sources typically provided by open source developers.")
(lambda _
(patch-shebang "get-version")
(with-output-to-file ".dist-version"
- (lambda () (display ,version)))
- #t))
+ (lambda () (display ,version)))))
(add-after 'unpack 'set-perl-libdir
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -363,8 +361,7 @@ other apt sources typically provided by open source developers.")
(setenv "PERL_LIBDIR"
(string-append out
"/lib/perl5/site_perl/"
- ,(package-version perl)))
- #t))))))
+ ,(package-version perl)))))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)