aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-17 00:08:34 +0200
commitf5961dd5854cec1ed9a41365836d63aa15256642 (patch)
tree9e6168827adf5e4e90128d55fad6f0ab6448c86a /gnu/packages/databases.scm
parent05bb85fda06dc361b8d3d1eef0759606784b3130 (diff)
parente28ff04108ae7506a21d451cc23d63937076e2a3 (diff)
downloadguix-f5961dd5854cec1ed9a41365836d63aa15256642.tar
guix-f5961dd5854cec1ed9a41365836d63aa15256642.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm110
1 files changed, 110 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 11ca214f7c..ed46f897b0 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -82,6 +82,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
+ #:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
@@ -984,6 +985,92 @@ for example from a shell script.")
;; others (like sparql-query.c) contain a GPLv2+ license header.
(license (list license:gpl3+))))
+(define-public sqitch
+ (package
+ (name "sqitch")
+ (version "0.9999")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/App-Sqitch-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1cvj8grs3bzc4g7dw1zc26g4biv1frav18sq0fkvi2kk0q1aigzm"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-check-environment
+ (lambda _
+ (setenv "TZ" "UTC")
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (path (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/bin/sqitch")
+ `("PERL5LIB" ":" prefix
+ (,(string-append out "/lib/perl5/site_perl"
+ ":"
+ path)))))
+ #t)))))
+ (native-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-io-pager" ,perl-io-pager)
+ ("perl-module-build" ,perl-module-build)
+ ("perl-module-runtime" ,perl-module-runtime)
+ ("perl-path-class" ,perl-path-class)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-dir" ,perl-test-dir)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-file" ,perl-test-file)
+ ("perl-test-file-contents" ,perl-test-file-contents)
+ ("perl-test-mockmodule" ,perl-test-mockmodule)
+ ("perl-test-nowarnings" ,perl-test-nowarnings)
+ ("perl-test-warn" ,perl-test-warn)))
+ (inputs
+ `(("perl-class-xsaccessor" ,perl-class-xsaccessor)
+ ("perl-clone" ,perl-clone)
+ ("perl-config-gitlike" ,perl-config-gitlike)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-datetime-timezone" ,perl-datetime-timezone)
+ ("perl-dbd-pg" ,perl-dbd-pg)
+ ("perl-dbi" ,perl-dbi)
+ ("perl-devel-stacktrace" ,perl-devel-stacktrace)
+ ("perl-encode-locale" ,perl-encode-locale)
+ ("perl-file-homedir" ,perl-file-homedir)
+ ("perl-hash-merge" ,perl-hash-merge)
+ ("perl-ipc-run3" ,perl-ipc-run3)
+ ("perl-ipc-system-simple" ,perl-ipc-system-simple)
+ ("perl-libintl-perl" ,perl-libintl-perl)
+ ("perl-list-moreutils" ,perl-list-moreutils)
+ ("perl-moo" ,perl-moo)
+ ("perl-mysql-config" ,perl-mysql-config)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)
+ ("perl-path-class" ,perl-path-class)
+ ("perl-perlio-utf8_strict" ,perl-perlio-utf8_strict)
+ ("perl-string-formatter" ,perl-string-formatter)
+ ("perl-string-shellquote" ,perl-string-shellquote)
+ ("perl-sub-exporter" ,perl-sub-exporter)
+ ("perl-template-tiny" ,perl-template-tiny)
+ ("perl-template-toolkit" ,perl-template-toolkit)
+ ("perl-throwable" ,perl-throwable)
+ ("perl-try-tiny" ,perl-try-tiny)
+ ("perl-type-tiny" ,perl-type-tiny)
+ ("perl-type-tiny-xs" ,perl-type-tiny-xs)
+ ("perl-uri" ,perl-uri)
+ ("perl-uri-db" ,perl-uri-db)))
+ (home-page "https://sqitch.org/")
+ (synopsis "Database change management tool")
+ (description
+ "Sqitch is a standalone change management system for database schemas,
+which uses SQL to describe changes.")
+ (license license:x11)))
+
(define-public sqlcrush
;; Unfortunately, there is no proper upstream release and may never be.
(let ((commit "b5f6868f189566a26eecc78d0f0659813c1aa98a")
@@ -1319,6 +1406,29 @@ module, and nothing else.")
(license license:perl-license)
(home-page "https://metacpan.org/release/DBD-SQLite")))
+(define-public perl-mysql-config
+ (package
+ (name "perl-mysql-config")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DARREN/MySQL-Config-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1svn7ccw2gc4cazvc58j84rxhnc9vs01zpird0l8460598j475qr"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/MySQL-Config")
+ (synopsis "Parse and utilize MySQL's /etc/my.cnf and ~/.my.cnf files")
+ (description
+ "@code{MySQL::Config} emulates the @code{load_defaults} function from
+libmysqlclient. It will fill an aray with long options, ready to be parsed by
+@code{Getopt::Long}.")
+ (license license:perl-license)))
+
(define-public perl-sql-abstract
(package
(name "perl-sql-abstract")