aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-04 23:10:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-07 21:33:44 +0100
commitc7bd735bc496223caadc13f90f7aa3b598485c64 (patch)
tree5487f82e30069466f116a759f90dbfd2e7c74f9b /gnu/packages/databases.scm
parente582f27a53ffb816f807e6e0014fcfca9d92c226 (diff)
downloadguix-c7bd735bc496223caadc13f90f7aa3b598485c64.tar
guix-c7bd735bc496223caadc13f90f7aa3b598485c64.tar.gz
gnu: sqls: Use go-1.21.
Merge all inputs into native-inputs since the output result of the package is an executable that does not require sources from Golang modules to be available after installation. * gnu/packages/databases.scm (sqls): [arguments]: <#:go>: Use go-1.21. [inputs]: Remove go-github-com-go-sql-driver-mysql, go-github-com-lib-pq, go-github-com-mattn-go-runewidth, go-github-com-mattn-go-sqlite3, go-github-com-olekukonko-tablewriter, go-github-com-pkg-errors, go-github-com-sourcegraph-jsonrpc2, go-golang-org-x-crypto, go-golang-org-x-xerrors, and go-gopkg-in-yaml-v2. [native-inputs]: Add go-github-com-go-sql-driver-mysql, go-github-com-lib-pq, go-github-com-mattn-go-runewidth, go-github-com-mattn-go-sqlite3, go-github-com-olekukonko-tablewriter, go-github-com-pkg-errors, go-github-com-sourcegraph-jsonrpc2, go-golang-org-x-crypto, go-golang-org-x-xerrors, and go-gopkg-in-yaml-v2. Change-Id: I9312a483dfa954b5f0ad4cfac04b5153570bf571
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 234f30e857..7759195ed5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5442,6 +5442,8 @@ compatible with SQLite using a graphical user interface.")
(define-public sqls
(package
(name "sqls")
+ ;; TODO: The latest version requires a way more packages to be available
+ ;; in Guix.
(version "0.2.18")
(source (origin
(method git-fetch)
@@ -5455,20 +5457,22 @@ compatible with SQLite using a graphical user interface.")
(build-system go-build-system)
(arguments
(list
+ #:go go-1.21
#:install-source? #f
#:import-path "github.com/lighttiger2505/sqls"))
- (inputs (list go-github-com-go-sql-driver-mysql
- go-github-com-lib-pq
- go-github-com-mattn-go-runewidth
- go-github-com-mattn-go-sqlite3
- go-github-com-olekukonko-tablewriter
- go-github-com-pkg-errors
- go-github-com-sourcegraph-jsonrpc2
- go-golang-org-x-crypto
- go-golang-org-x-xerrors
- go-gopkg-in-yaml-v2))
- (native-inputs (list go-github-com-google-go-cmp-cmp
- go-github-com-k0kubun-pp))
+ (native-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-go-sql-driver-mysql
+ go-github-com-k0kubun-pp
+ go-github-com-lib-pq
+ go-github-com-mattn-go-runewidth
+ go-github-com-mattn-go-sqlite3
+ go-github-com-olekukonko-tablewriter
+ go-github-com-pkg-errors
+ go-github-com-sourcegraph-jsonrpc2
+ go-golang-org-x-crypto
+ go-golang-org-x-xerrors
+ go-gopkg-in-yaml-v2))
(home-page "https://github.com/sqls-server/sqls")
(synopsis "SQL language server written in Go")
(description