aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-30 18:36:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commit8647aaaa1404b2dd3931b53489178e79de40fa6c (patch)
tree6e8592d5ca6ebd6d4398998f9d6e47b16b81b200 /gnu/packages/databases.scm
parent442eba98be21518423f2cf0a10d1fa5d6c7865ca (diff)
downloadguix-8647aaaa1404b2dd3931b53489178e79de40fa6c.tar
guix-8647aaaa1404b2dd3931b53489178e79de40fa6c.tar.gz
gnu: apache-arrow: Build with ORC.
* gnu/packages/databases.scm (apache-arrow)[arguments]: Set options needed to build with ORC support; remove unused options -DBENCHMARK_ENABLE_GTEST_TESTS=OFF and -DARROW_GLOG=ON. [inputs]: Add apache-orc. Change-Id: Icabe6e3a73478c8464ea1e8efc103899da8e5a86
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm123
1 files changed, 62 insertions, 61 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 8ad73e400a..fd9a0a6d97 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -4626,68 +4626,69 @@ with integrated support for finding required rows quickly.")
(setenv "BROTLI_HOME" #$(this-package-input "brotli"))
(setenv "FLATBUFFERS_HOME" #$(this-package-input "flatbuffers"))
(setenv "RAPIDJSON_HOME" #$(this-package-input "rapidjson")))))
- #:build-type "Release"
- #:configure-flags
- #~(list "-DARROW_PYTHON=ON"
- "-DARROW_GLOG=ON"
- ;; Parquet options
- "-DARROW_PARQUET=ON"
- "-DPARQUET_BUILD_EXECUTABLES=ON"
- ;; The maintainers disallow using system versions of
- ;; jemalloc:
- ;; https://issues.apache.org/jira/browse/ARROW-3507. This
- ;; is unfortunate because jemalloc increases performance:
- ;; https://arrow.apache.org/blog/2018/07/20/jemalloc/.
- "-DARROW_JEMALLOC=OFF"
-
- ;; The CMake option ARROW_DEPENDENCY_SOURCE is a global
- ;; option that instructs the build system how to resolve
- ;; each dependency. SYSTEM = Finding the dependency in
- ;; system paths using CMake's built-in find_package
- ;; function, or using pkg-config for packages that do not
- ;; have this feature
- "-DARROW_DEPENDENCY_SOURCE=SYSTEM"
- "-Dxsimd_SOURCE=SYSTEM"
-
- "-DARROW_RUNTIME_SIMD_LEVEL=NONE"
- "-DARROW_SIMD_LEVEL=NONE"
- "-DARROW_PACKAGE_KIND=Guix"
-
- ;; Split output into its component packages.
- (string-append "-DCMAKE_INSTALL_PREFIX=" #$output:lib)
- (string-append "-DCMAKE_INSTALL_RPATH=" #$output:lib "/lib")
- (string-append "-DCMAKE_INSTALL_BINDIR=" #$output "/bin")
- (string-append "-DCMAKE_INSTALL_INCLUDEDIR=" #$output:include
- "/share/include")
-
- "-DARROW_WITH_SNAPPY=ON"
- "-DARROW_WITH_ZLIB=ON"
- "-DARROW_WITH_ZSTD=ON"
- "-DARROW_WITH_LZ4=ON"
- "-DARROW_COMPUTE=ON"
- "-DARROW_CSV=ON"
- "-DARROW_DATASET=ON"
- "-DARROW_FILESYSTEM=ON"
- "-DARROW_HDFS=ON"
- "-DARROW_JSON=ON"
- ;; Arrow Python C++ integration library (required for
- ;; building pyarrow). This library must be built against
- ;; the same Python version for which you are building
- ;; pyarrow. NumPy must also be installed. Enabling this
- ;; option also enables ARROW_COMPUTE, ARROW_CSV,
- ;; ARROW_DATASET, ARROW_FILESYSTEM, ARROW_HDFS, and
- ;; ARROW_JSON.
- "-DARROW_PYTHON=ON"
-
- ;; Building the tests forces on all the
- ;; optional features and the use of static
- ;; libraries.
- "-DARROW_BUILD_TESTS=OFF"
- "-DBENCHMARK_ENABLE_GTEST_TESTS=OFF"
- ;;"-DBENCHMARK_ENABLE_TESTING=OFF"
- "-DARROW_BUILD_STATIC=OFF")))
+ #:build-type "Release"
+ #:configure-flags
+ #~(list "-DARROW_PYTHON=ON"
+ ;; Parquet options
+ "-DARROW_PARQUET=ON"
+ "-DPARQUET_BUILD_EXECUTABLES=ON"
+ ;; The maintainers disallow using system versions of
+ ;; jemalloc:
+ ;; https://issues.apache.org/jira/browse/ARROW-3507. This
+ ;; is unfortunate because jemalloc increases performance:
+ ;; https://arrow.apache.org/blog/2018/07/20/jemalloc/.
+ "-DARROW_JEMALLOC=OFF"
+
+ ;; The CMake option ARROW_DEPENDENCY_SOURCE is a global
+ ;; option that instructs the build system how to resolve
+ ;; each dependency. SYSTEM = Finding the dependency in
+ ;; system paths using CMake's built-in find_package
+ ;; function, or using pkg-config for packages that do not
+ ;; have this feature
+ "-DARROW_DEPENDENCY_SOURCE=SYSTEM"
+ "-Dxsimd_SOURCE=SYSTEM"
+
+ "-DARROW_RUNTIME_SIMD_LEVEL=NONE"
+ "-DARROW_SIMD_LEVEL=NONE"
+ "-DARROW_PACKAGE_KIND=Guix"
+
+ ;; Split output into its component packages.
+ (string-append "-DCMAKE_INSTALL_PREFIX=" #$output:lib)
+ (string-append "-DCMAKE_INSTALL_RPATH=" #$output:lib "/lib")
+ (string-append "-DCMAKE_INSTALL_BINDIR=" #$output "/bin")
+ (string-append "-DCMAKE_INSTALL_INCLUDEDIR=" #$output:include
+ "/share/include")
+
+ "-DARROW_WITH_SNAPPY=ON"
+ "-DARROW_WITH_ZLIB=ON"
+ "-DARROW_WITH_ZSTD=ON"
+ "-DARROW_WITH_LZ4=ON"
+ "-DARROW_COMPUTE=ON"
+ "-DARROW_CSV=ON"
+ "-DARROW_DATASET=ON"
+ "-DARROW_FILESYSTEM=ON"
+ "-DARROW_HDFS=ON"
+ "-DARROW_JSON=ON"
+ ;; Arrow Python C++ integration library (required for
+ ;; building pyarrow). This library must be built against
+ ;; the same Python version for which you are building
+ ;; pyarrow. NumPy must also be installed. Enabling this
+ ;; option also enables ARROW_COMPUTE, ARROW_CSV,
+ ;; ARROW_DATASET, ARROW_FILESYSTEM, ARROW_HDFS, and
+ ;; ARROW_JSON.
+ "-DARROW_PYTHON=ON"
+ "-DARROW_ORC=ON"
+ "-DORC_SOURCE=SYSTEM"
+
+ ;; Building the tests forces on all the
+ ;; optional features and the use of static
+ ;; libraries.
+ "-DARROW_BUILD_TESTS=OFF"
+ ;;"-DBENCHMARK_ENABLE_TESTING=OFF"
+ "-DARROW_BUILD_STATIC=OFF")))
(inputs
- (list boost
+ (list apache-orc
+ boost
brotli
bzip2
double-conversion