aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 22:06:33 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 22:06:33 +0000
commit27adf51a581772dca6cd99ffa0a43f8f748c7a7e (patch)
treef4d468909a60bb8fe6810afc7dc85aeb3227e63b /gnu/packages/databases.scm
parent40d697a30140321865f2c3fff28711d543673474 (diff)
downloadguix-27adf51a581772dca6cd99ffa0a43f8f748c7a7e.tar
guix-27adf51a581772dca6cd99ffa0a43f8f748c7a7e.tar.gz
gnu: sqls: Fix home and source URL.
* gnu/packages/databases.scm (sqls): Place [home-page] after [native-inputs]. [source]: Swap to use direct source URL string instead of home page. [arguments]: Use list format. Set <#:install-source?> to #t. [home-page]: Fix URL after lint permanent redirect warning. [inputs]: Sort alphabetically. Change-Id: I50f1c9b38efb5774f6d95d79c4f5f8e1774fd75e
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a1b689744b..56f100e841 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -5352,11 +5352,10 @@ compatible with SQLite using a graphical user interface.")
(package
(name "sqls")
(version "0.2.18")
- (home-page "https://github.com/lighttiger2505/sqls")
(source (origin
(method git-fetch)
(uri (git-reference
- (url home-page)
+ (url "https://github.com/sqls-server/sqls")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
@@ -5364,19 +5363,22 @@ compatible with SQLite using a graphical user interface.")
"13837v27avdp2nls3vyy7ml12nj7rxragchwf92adn10ffp4aj6c"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/lighttiger2505/sqls"))
+ (list
+ #:install-source? #f
+ #:import-path "github.com/lighttiger2505/sqls"))
(inputs (list go-github-com-go-sql-driver-mysql
go-github-com-lib-pq
+ go-github-com-mattn-go-runewidth
go-github-com-mattn-go-sqlite3
go-github-com-olekukonko-tablewriter
go-github-com-pkg-errors
go-github-com-sourcegraph-jsonrpc2
go-golang-org-x-crypto
- go-github-com-mattn-go-runewidth
go-golang-org-x-xerrors
go-gopkg-in-yaml-v2))
(native-inputs (list go-github-com-google-go-cmp-cmp
go-github-com-k0kubun-pp))
+ (home-page "https://github.com/sqls-server/sqls")
(synopsis "SQL language server written in Go")
(description
"This package implements the @acronym{LSP, Language Server Protocol} for SQL.")