aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-01 22:43:58 +0200
committerMarius Bakke <marius@gnu.org>2022-09-01 23:37:12 +0200
commitf807d1795fbdc7e3c9e63df36114f332e6f7f304 (patch)
treeb7b9735c8cc5806dd27c6d004e43cdbd8b3092d4 /gnu/packages/curl.scm
parent648f3d5d4934bf7545e840377df4f3fc1ead6b41 (diff)
downloadguix-f807d1795fbdc7e3c9e63df36114f332e6f7f304.tar
guix-f807d1795fbdc7e3c9e63df36114f332e6f7f304.tar.gz
gnu: cURL: Update to 7.85.0.
* gnu/packages/curl.scm (curl): Update to 7.85.0. [source](patches): Remove obsolete. [arguments]: Remove obsolete phase. * gnu/packages/patches/curl-easy-lock.patch, gnu/packages/patches/curl-nghttp2-compat.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 600163bf72..c91e268ef5 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -63,17 +63,15 @@
(define-public curl
(package
(name "curl")
- (version "7.84.0")
+ (version "7.85.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "1f2xgj0wvys9xw50h7vcbaraavjr9rxx9n06x2xfbgs7ym1qn49d"))
- (patches (search-patches "curl-use-ssl-cert-env.patch"
- "curl-nghttp2-compat.patch"
- "curl-easy-lock.patch"))))
+ "1rjbn0h5rddclhvxb8p5gddxszcrpbf5cw1whx6wnj4s9dnlmdc8"))
+ (patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -105,12 +103,6 @@
"--disable-static")
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'tweak-lib3026-test
- (lambda _
- ;; Have that test create a hundred threads, not a thousand.
- (substitute* "tests/libtest/lib3026.c"
- (("NUM_THREADS .*$")
- "NUM_THREADS 100\n"))))
(add-after 'unpack 'do-not-record-configure-flags
(lambda _
;; Do not save the configure options to avoid unnecessary references.