aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-12-17 01:11:32 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-12-17 01:27:00 -0500
commitbc7713fa8878ab8a2158c8660d9b2bbb8fb2f77e (patch)
treeca0ec15c5835a2a2647510206ae1b2d9cb550b3f /gnu/packages/curl.scm
parent158502e40d800407f1bd697dd5dd0437086730bf (diff)
downloadguix-bc7713fa8878ab8a2158c8660d9b2bbb8fb2f77e.tar
guix-bc7713fa8878ab8a2158c8660d9b2bbb8fb2f77e.tar.gz
gnu: curl: Update to 8.5.0 [security fixes].
Fixes CVE-2023-46218 and CVE-2023-46219. See <https://curl.se/docs/CVE-2023-46218.html> and <https://curl.se/docs/CVE-2023-46219.html> respectively. * gnu/packages/curl.scm (curl): Update to 8.5.0. * gnu/packages/patches/curl-use-ssl-cert-env.patch: Update patch. Change-Id: Iaa6aa5de0f45576dc06bf5eca1eec502e5c83332
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index b33f4d36d4..0bf6d996e6 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -65,14 +65,14 @@
(define-public curl
(package
(name "curl")
- (version "8.4.0")
+ (version "8.5.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "0bd8y8v66biyqvg70ka1sdd0aixs6yzpnvfsig907xzh9af2mihn"))
+ "1sqfflilf7mcz1g03lazyr6v6pf1rsrzprrknsir10hdwawqvas2"))
(patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
@@ -127,6 +127,9 @@
(if parallel-tests?
(number->string (parallel-job-count))
"1")))
+ ;; Ignore test 1477 due to a missing file in the 8.5.0
+ ;; release. See
+ ;; <https://github.com/curl/curl/issues/12462>.
(arguments `("-C" "tests" "test"
,@make-flags
,(if #$(or (system-hurd?)
@@ -134,8 +137,10 @@
(target-aarch64?))
;; protocol FAIL
(string-append "TFLAGS=\"~1474 "
+ "~1477 "
job-count "\"")
- (string-append "TFLAGS=" job-count)))))
+ (string-append "TFLAGS=\"~1477 "
+ job-count "\"")))))
;; The top-level "make check" does "make -C tests quiet-test", which
;; is too quiet. Use the "test" target instead, which is more
;; verbose.