aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-21 21:53:29 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-25 11:47:51 +0200
commit11f078a1fb332c1ec242e1defe4c66b4f5ef5de6 (patch)
treebd4216059c2b554bc2a76147955d30cf97b98fe8 /gnu/packages/curl.scm
parent26cdc7be84623b1e99d0d0f85124c7d4b4469c00 (diff)
downloadguix-11f078a1fb332c1ec242e1defe4c66b4f5ef5de6.tar
guix-11f078a1fb332c1ec242e1defe4c66b4f5ef5de6.tar.gz
gnu: Add trurl.
* gnu/packages/curl.scm (trurl): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 4bfb0572a3..0c404881d7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -413,3 +414,39 @@ curl, curlie is what you are searching for. Curlie is a frontend to
on features and performance. All @code{curl} options are exposed with syntax
sugar and output formatting inspired from @code{httpie}.")
(license license:expat)))
+
+(define-public trurl
+ (package
+ (name "trurl")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/curl/trurl")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1mvkpjs6wnz5hzmp2iglik85zljrzglsa6fm839l78fhw89dg3w6"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:test-target "test"
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs (list python))
+ ;; Tests failed on older curl version
+ ;; (see https://github.com/curl/trurl/pull/165)
+ (inputs (list curl-7.84.0))
+ (home-page "https://curl.se/trurl/")
+ (synopsis "Command line tool for URL parsing and manipulatio")
+ (description "@code{trurl} is a tool in a similar spirit of @code{tr} but
+for URLs. Here, @code{tr} stands for translate or transpose.
+
+@code{trurl} is a command line tool that parses and manipulates URLs, designed
+to help shell script authors everywhere.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))