aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-07 02:00:00 +0200
commite315d9a8024e8964f6bd066b4a2ac8d626754e80 (patch)
treef8ff437329a53f50718c208d66a8ec79c3ea4cad /gnu/packages/cups.scm
parent56b55a13f659be21c78d33c839485e6d0ba9e22a (diff)
downloadguix-e315d9a8024e8964f6bd066b4a2ac8d626754e80.tar
guix-e315d9a8024e8964f6bd066b4a2ac8d626754e80.tar.gz
gnu: cups-pk-helper: Add etc/dbus-1 compatibility symlink.
* gnu/packages/cups.scm (cups-pk-helper)[arguments]: Add an 'install-compatibility-symlink phase.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 5070ab6693..3de9ddbf22 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -477,9 +477,20 @@ device-specific programs to convert and print many types of files.")
(build-system meson-build-system)
(arguments
;; XXX The tests require a running D-Bus and CUPS daemon, of course.
- (list #:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-compatibility-symlink
+ ;; XXX Upstream (and, presumably, the world) has moved to
+ ;; /share/dbus-1 over /etc/dbus-1, but Guix System's
+ ;; dbus-configuration-directory has yet to catch up.
+ ;; TODO It should be properly fixed and this phase removed.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (with-directory-excursion (assoc-ref outputs "out")
+ (mkdir-p "etc")
+ (symlink "../share/dbus-1" "etc/dbus-1")))))))
(native-inputs
- (list pkg-config `(,glib "bin")))
+ (list intltool pkg-config `(,glib "bin")))
(inputs
(list glib polkit cups-minimal))
(home-page "https://www.freedesktop.org/wiki/Software/cups-pk-helper/")