aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-25 21:22:08 -0500
committerLeo Famulari <leo@famulari.name>2017-02-26 11:39:08 -0500
commitd043ceedbb3ce1873db97cfe2c8806de64881f01 (patch)
tree98d84b50b44c45c6869977812719262731d3b864 /gnu/packages/cups.scm
parent9a9d6d782c4752124912e545b411ed8189e2d754 (diff)
downloadguix-d043ceedbb3ce1873db97cfe2c8806de64881f01.tar
guix-d043ceedbb3ce1873db97cfe2c8806de64881f01.tar.gz
gnu: cups-minimal: Fix build failure in reset-gzip-timestamps phase.
* gnu/packages/cups.scm (cups-minimal)[arguments]: Add 'make-manpages-writable' phase.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 20621e32b7..2649cd3469 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -166,6 +166,14 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(substitute* "Makedefs.in"
(("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
(("/bin/sh") (which "sh")))))
+ ;; Make the compressed manpages writable so that the
+ ;; reset-gzip-timestamps phase does not error out.
+ (add-before 'reset-gzip-timestamps 'make-manpages-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man")))
+ (for-each (lambda (file) (chmod file #o644))
+ (find-files man "\\.gz")))))
(add-before 'build 'patch-tests
(lambda _
(substitute* "test/ippserver.c"