aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-10-17 22:43:56 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-10-26 11:30:01 +0200
commit23376668339b126b0270bcfcea9d9044903ff05e (patch)
treee9ebe58a2c10d2bd1e8da949e67ec49a9d221f51 /gnu/packages/cups.scm
parenta7083cab3a67a3a0198a61d39011cdeb9427f1d9 (diff)
downloadguix-23376668339b126b0270bcfcea9d9044903ff05e.tar
guix-23376668339b126b0270bcfcea9d9044903ff05e.tar.gz
gnu: cups: Fix cross-compiling.
* gnu/packages/cups.scm (cups-filters)[native-inputs]: When cross-compiling add cups-minimal. (cups-minimal)[native-inputs]: When cross-compiling add this-package. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Change-Id: Ifcc34f09d0a5afb3a1b95be51715c509b8ef5ed4
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index fc3ff52cbe..731091ea7d 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -204,8 +205,11 @@ driver is known to work with these printers:
(find-files (string-append #$output
"/lib/cups/filter"))))))))
(native-inputs
- (list `(,glib "bin") ; for gdbus-codegen
- pkg-config))
+ (append (if (%current-target-system)
+ (list cups-minimal)
+ '())
+ (list `(,glib "bin") ; for gdbus-codegen
+ pkg-config)))
(inputs
(list avahi
fontconfig
@@ -315,7 +319,10 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
;; to a missing font. Substitute the last observed count.
(("(\\$count != )33" _ prefix)
(string-append prefix "39"))))))))
- (native-inputs (list config pkg-config))
+ (native-inputs (cons* config pkg-config
+ (if (%current-target-system)
+ (list this-package)
+ '())))
(inputs (list zlib gnutls))
(home-page "https://openprinting.github.io/cups")
(synopsis "The Common Unix Printing System")