aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cryptsetup.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2023-12-17 00:59:29 +0200
committerMathieu Othacehe <othacehe@gnu.org>2023-12-23 10:47:13 +0100
commitd211e54510d88b19a74383e780bdfe70b9686c8b (patch)
treefa83423f14adbbb354e478cf65dad1b75aa6c245 /gnu/packages/cryptsetup.scm
parent304d5193860ad4d378896fe81c25c76798deb261 (diff)
downloadguix-d211e54510d88b19a74383e780bdfe70b9686c8b.tar
guix-d211e54510d88b19a74383e780bdfe70b9686c8b.tar.gz
gnu: cryptsetup: Fix cross-compilation.
* gnu/packages/cryptsetup.scm (cryptsetup): Set explicit `--with-libgcrypt-prefix' for cross-compilation. Change-Id: I39b8d07926865dd168f9db8d3eb84fafbf3f3c56 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/cryptsetup.scm')
-rw-r--r--gnu/packages/cryptsetup.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index d8a6437259..3bdc68ae5a 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -53,7 +53,11 @@
;; The default is OpenSSL which provides better PBKDF performance.
"--with-crypto_backend=gcrypt"
;; GRUB 2.06 supports LUKS2, but does it reliably support all set-ups…?
- "--with-default-luks-format=LUKS1")))
+ "--with-default-luks-format=LUKS1"
+ ;; libgcrypt is not found otherwise when cross-compiling.
+ ;; <https://issues.guix.gnu.org/63864>
+ (string-append "--with-libgcrypt-prefix="
+ (assoc-ref %build-inputs "libgcrypt")))))
(native-inputs
(list pkg-config))
(inputs