aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-01-09 23:11:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-01-09 23:15:09 +0200
commitfa58a0a62e28db8f351222ee238ebb929b2b3bdb (patch)
tree229d859420ddc44a3f9663b926b7dc88a832ae78 /gnu/packages/crypto.scm
parent513dc568ca36d065f618f06c677db6d82240e9ff (diff)
downloadguix-fa58a0a62e28db8f351222ee238ebb929b2b3bdb.tar
guix-fa58a0a62e28db8f351222ee238ebb929b2b3bdb.tar.gz
gnu: libb2: Only check for CPU optimisations on Intel architectures.
* gnu/packages/crypto.scm (libb2)[arguments]: Only pass the configure-flag '--enable-fat' on i686 or x86_64.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 4ecdaa8f7f..e616c9223f 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016, 2017 ng0 <ng0@infotropique.org>
;;; Copyright © 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -56,7 +57,9 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system perl))
+ #:use-module (guix build-system perl)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26))
(define-public libsodium
(package
@@ -634,8 +637,14 @@ data on your platform, so the seed itself will be as random as possible.
("libtool" ,libtool)))
(arguments
`(#:configure-flags
- (list "--enable-fat" ; detect optimisations at run time...
- "--disable-native") ; ...not build time
+ (list
+ ,@(if (any (cute string-prefix? <> (or (%current-system)
+ (%current-target-system)))
+ '("x86_64" "i686"))
+ ;; fat only checks for Intel optimisations
+ '("--enable-fat")
+ '())
+ "--disable-native") ; don't optimise at build time.
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'bootstrap