aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-12-11 01:00:03 +0100
commitd1c3681e38a3ea70d1ce4df1077fba11fb88508b (patch)
tree78c16a2c6947493a0efdeb92c16e5a8c0bcca79c /gnu/packages/crypto.scm
parenta78e2675925c93b1bded910880d48379a365675e (diff)
downloadguix-d1c3681e38a3ea70d1ce4df1077fba11fb88508b.tar
guix-d1c3681e38a3ea70d1ce4df1077fba11fb88508b.tar.gz
gnu: olm: Drop custom ‘lib-’ prefix.
* gnu/packages/crypto.scm (olm): New variable, renamed from… (libolm): …this one, which is now a DEPRECATED-PACKAGE alias of olm. Adjust all users. [synopsis, description]: Adjust. Capitalise proper nouns. (python-olm)[description]: Remove implementation detail.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index cc633cb4bf..791de39368 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1293,9 +1293,9 @@ signatures include trusted comments in addition to untrusted comments.
Trusted comments are signed, thus verified, before being displayed.")
(license license:isc)))
-(define-public libolm
+(define-public olm
(package
- (name "libolm")
+ (name "olm")
(version "3.2.12")
(source (origin
(method git-fetch)
@@ -1319,13 +1319,16 @@ Trusted comments are signed, thus verified, before being displayed.")
(when tests?
(with-directory-excursion "tests"
(invoke "ctest" "."))))))))
- (synopsis "Implementation of the olm and megolm cryptographic ratchets")
- (description "The libolm library implements the Double Ratchet
+ (synopsis "Implementation of the Olm and Megolm cryptographic ratchets")
+ (description "The Olm library implements the Double Ratchet
cryptographic ratchet. It is written in C and C++11, and exposed as a C
API.")
(home-page "https://matrix.org/docs/projects/other/olm/")
(license license:asl2.0)))
+(define-public libolm
+ (deprecated-package "libolm" olm))
+
(define-public python-olm
(package
;; python-olm is part of libolm and must be updated at the same time.
@@ -1351,10 +1354,9 @@ API.")
(list python-cffi python-future))
(native-inputs
(list python-pytest python-pytest-benchmark python-aspectlib))
- (synopsis "Python bindings for libolm")
- (description "The libolm library implements the Double Ratchet
-cryptographic ratchet. It is written in C and C++11, and exposed as a C
-API. This package contains its Python bindings.")))
+ (synopsis "Python bindings for Olm")
+ (description "The Olm library implements the Double Ratchet
+cryptographic ratchet. This package contains its Python bindings.")))
(define-public hash-extender
(let ((commit "cb8aaee49f93e9c0d2f03eb3cafb429c9eed723d")