aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cross-toolchain.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-11-28 12:35:00 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-12-11 13:37:21 +0200
commita9a51b0dca2b228ce334bf36db77af015d3b1285 (patch)
treecf1e6e99e20aebdc32280b980e565f6e8a12ec73 /gnu/packages/cross-toolchain.scm
parentf9cb95d9b4e211652c05018fa7d4acff15f86f5c (diff)
downloadguix-a9a51b0dca2b228ce334bf36db77af015d3b1285.tar
guix-a9a51b0dca2b228ce334bf36db77af015d3b1285.tar.gz
gnu: Add gcc-cross-avr-toolchain.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add cross-toolchain.scm. * gnu/packages/cross-toolchain.scm (gcc-cross-avr-toolchain): New variable. Change-Id: Ie768d5cc0663dd57753af1d4ac631b3cafbf9e8c Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/cross-toolchain.scm')
-rw-r--r--gnu/packages/cross-toolchain.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cross-toolchain.scm b/gnu/packages/cross-toolchain.scm
new file mode 100644
index 0000000000..08511a7c00
--- /dev/null
+++ b/gnu/packages/cross-toolchain.scm
@@ -0,0 +1,36 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages cross-toolchain)
+ #:use-module (gnu packages cross-base)
+ #:use-module (guix packages))
+
+;;; Commentary:
+;;;
+;;; This module provides packages for cross compilation toolchains. These
+;;; packages must not be used at the top level to avoid cyclic module
+;;; dependencies caused by the (gnu packages cross-base) module referring to
+;;; to top level bindings from (gnu packages gcc).
+;;;
+;;; The real purpose of these packages is for installation on profiles by users
+;;; and other packages should make use of the toolchain through the usual cross
+;;; compilation methods. For example, by using the `#:target' argument on
+;;; packages or `--target' on the command line.
+
+(define-public gcc-cross-avr-toolchain
+ (cross-gcc-toolchain "avr"))