aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 11:22:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:31 +0200
commitf60b87e60f181fa76dfe6c0bcedbaae625494236 (patch)
tree444ad5a1149e393c68ab7aae740114fd9edce6f3 /gnu/packages/crates-web.scm
parentc783065457b35a7b5e4a6232b67a35fbf1961f11 (diff)
downloadguix-f60b87e60f181fa76dfe6c0bcedbaae625494236.tar
guix-f60b87e60f181fa76dfe6c0bcedbaae625494236.tar.gz
gnu: rust-tungstenite: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-tungstenite-0.19, rust-tungstenite-0.11): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: I21e426a3d03a5865efe704b75ee4e14873636462
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 3d79f4f13c..b4bc5efacb 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -4343,6 +4343,80 @@ the Trust-DNS client to use rustls for TLS.")
(("rust-openssl" ,rust-openssl-0.10)
("rust-tokio" ,rust-tokio-0.1))))))
+(define-public rust-tungstenite-0.19
+ (package
+ (name "rust-tungstenite")
+ (version "0.19.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0rxzxg4y22rsvdvs4la7igy9117yidc2m6lsfm2hf0xvsska3yqm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-data-encoding" ,rust-data-encoding-2)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-httparse" ,rust-httparse-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rustls" ,rust-rustls-0.21)
+ ("rust-rustls-native-certs" ,rust-rustls-native-certs-0.6)
+ ("rust-sha1" ,rust-sha1-0.10)
+ ("rust-thiserror" ,rust-thiserror-1)
+ ("rust-url" ,rust-url-2)
+ ("rust-utf-8" ,rust-utf-8-0.7)
+ ("rust-webpki" ,rust-webpki-0.22)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.23))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.4)
+ ("rust-env-logger" ,rust-env-logger-0.10)
+ ("rust-input-buffer" ,rust-input-buffer-0.5)
+ ("rust-net2" ,rust-net2-0.2)
+ ("rust-rand" ,rust-rand-0.8))))
+ (home-page "https://github.com/snapview/tungstenite-rs")
+ (synopsis "Lightweight stream-based WebSocket implementation")
+ (description
+ "This library provides an implementation of WebSockets, RFC6455. It
+allows for both synchronous (like TcpStream) and asynchronous usage and is
+easy to integrate into any third-party event loops including MIO. The API
+design abstracts away all the internals of the WebSocket protocol but still
+makes them accessible for those who wants full control over the network.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-tungstenite-0.11
+ (package
+ (inherit rust-tungstenite-0.19)
+ (name "rust-tungstenite")
+ (version "0.11.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tungstenite" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "08ra94x3zqkmbsrcmwszknxv2a8g08gk5xlyif3wa037v208sc7h"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-base64" ,rust-base64-0.12)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-0.5)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-httparse" ,rust-httparse-1)
+ ("rust-input-buffer" ,rust-input-buffer-0.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-native-tls" ,rust-native-tls-0.2)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-sha-1" ,rust-sha-1-0.9)
+ ("rust-url" ,rust-url-2)
+ ("rust-utf-8" ,rust-utf-8-0.7))))))
+
(define-public rust-warp-0.2
(package
(name "rust-warp")