aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2024-01-30 20:25:12 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:40 +0200
commitf2a75ae3b18bb0ff0018fdd049e60f53af99b2ce (patch)
treec8067514d39fb9ad267a7859ea7a577822c5ea8f /gnu/packages/crates-web.scm
parent8b0e8387b538fafaed9ddd12aeb2052105fd3c5f (diff)
downloadguix-f2a75ae3b18bb0ff0018fdd049e60f53af99b2ce.tar
guix-f2a75ae3b18bb0ff0018fdd049e60f53af99b2ce.tar.gz
gnu: Add rust-webpki-roots-0.26.
* gnu/packages/crates-web.scm (rust-webpki-roots-0.26): New variable. (rust-webpki-roots-0.25): Inherit from rust-webpki-roots-0.26. Change-Id: I3bd62f0ae0fbf08282bb8bee9b0e1c09dc1ee6e8 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm47
1 files changed, 36 insertions, 11 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 4e7024bcde..f57cc5c162 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -5042,8 +5042,43 @@ Verification.")
#:cargo-development-inputs
(("rust-base64" ,rust-base64-0.9))))))
+(define-public rust-webpki-roots-0.26
+ (package
+ (name "rust-webpki-roots")
+ (version "0.26.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "webpki-roots" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "029006qfs61q75gl60aap25m0gdqmvd1pcpljid9b0q44yp39pmk"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; use of undeclared crate or module `webpki_ccadb`
+ #:cargo-inputs (("rust-rustls-pki-types" ,rust-rustls-pki-types-1))
+ #:cargo-development-inputs (("rust-hex" ,rust-hex-0.4)
+ ("rust-percent-encoding" ,rust-percent-encoding-2)
+ ("rust-rcgen" ,rust-rcgen-0.12)
+ ("rust-ring" ,rust-ring-0.17)
+ ("rust-rustls" ,rust-rustls-0.22)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.102)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-x509-parser" ,rust-x509-parser-0.15)
+ ("rust-yasna" ,rust-yasna-0.5))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list openssl))
+ (home-page "https://github.com/rustls/webpki-roots")
+ (synopsis "Mozilla's CA root certificates for use with webpki")
+ (description "This package provides Mozilla's CA root certificates for use
+with webpki.")
+ (license license:mpl2.0)))
+
(define-public rust-webpki-roots-0.25
(package
+ (inherit rust-webpki-roots-0.26)
(name "rust-webpki-roots")
(version "0.25.1")
(source (origin
@@ -5053,7 +5088,6 @@ Verification.")
(sha256
(base32
"15piy0vccppqb74li32gnn9l5a4ysxzwh8bp3qv6z8rhr2hyvin9"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-test-flags
(list "--release" "--"
@@ -5065,16 +5099,7 @@ Verification.")
("rust-ring" ,rust-ring-0.16)
("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
- ("rust-tokio" ,rust-tokio-1))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list openssl))
- (home-page "https://github.com/rustls/webpki-roots")
- (synopsis "Mozilla's CA root certificates for use with webpki")
- (description "This package provides Mozilla's CA root certificates for use
-with webpki.")
- (license license:mpl2.0)))
+ ("rust-tokio" ,rust-tokio-1))))))
(define-public rust-webpki-roots-0.24
(package