aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:02:55 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:22 +0300
commitce9f4cc294b7a9d4d38fcd60e67a911f181729d1 (patch)
tree49b148cb937bcf709e1bde62f572593412c6e3ab /gnu/packages/crates-web.scm
parent5dd1fc7f710f79fa632ad467b6c0d18903d47958 (diff)
downloadguix-ce9f4cc294b7a9d4d38fcd60e67a911f181729d1.tar
guix-ce9f4cc294b7a9d4d38fcd60e67a911f181729d1.tar.gz
gnu: Add rust-hyper-1.
* gnu/packages/crates-web.scm (rust-hyper-1): Add variable. (rust-hyper-0.14): Inherit rust-hyper-1. Change-Id: I4a803247155cae29dab9e9d4bcf915196d8ee31f Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm53
1 files changed, 48 insertions, 5 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 5f750c2231..dbe5e7a8f2 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2896,8 +2896,55 @@ response bodies.")
"This crates parses and formats HTTP datetime strings.")
(license (list license:expat license:asl2.0))))
+(define-public rust-hyper-1
+ (package
+ (name "rust-hyper")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hyper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fi6k7hz5fmdph0a5r8hw50d7h2n9zxkizmafcmb65f67bblhr8q"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; unresolved imports `super::DecodedLength`, `super::Sender`
+ #:cargo-inputs (("rust-bytes" ,rust-bytes-1)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-h2" ,rust-h2-0.4)
+ ("rust-http" ,rust-http-1)
+ ("rust-http-body" ,rust-http-body-1)
+ ("rust-http-body-util" ,rust-http-body-util-0.1)
+ ("rust-httparse" ,rust-httparse-1)
+ ("rust-httpdate" ,rust-httpdate-1)
+ ("rust-itoa" ,rust-itoa-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-want" ,rust-want-0.3))
+ #:cargo-development-inputs
+ (("rust-form-urlencoded" ,rust-form-urlencoded-1)
+ ("rust-futures-channel" ,rust-futures-channel-0.3)
+ ("rust-futures-util" ,rust-futures-util-0.3)
+ ("rust-http-body-util" ,rust-http-body-util-0.1)
+ ("rust-pretty-env-logger" ,rust-pretty-env-logger-0.5)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-spmc" ,rust-spmc-0.3)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-test" ,rust-tokio-test-0.4)
+ ("rust-tokio-util" ,rust-tokio-util-0.7))))
+ (home-page "https://hyper.rs")
+ (synopsis "Fast and correct HTTP library")
+ (description "This package provides a fast and correct HTTP library.")
+ (license license:expat)))
+
(define-public rust-hyper-0.14
(package
+ (inherit rust-hyper-1)
(name "rust-hyper")
(version "0.14.27")
(source
@@ -2940,11 +2987,7 @@ response bodies.")
("rust-tokio-test" ,rust-tokio-test-0.4)
("rust-tokio-util" ,rust-tokio-util-0.7)
("rust-tower" ,rust-tower-0.4)
- ("rust-url" ,rust-url-2))))
- (home-page "https://hyper.rs")
- (synopsis "Fast and correct HTTP library")
- (description "This package provides a fast and correct HTTP library.")
- (license license:expat)))
+ ("rust-url" ,rust-url-2))))))
(define-public rust-hyper-0.13
(package