aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 14:36:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:57 +0200
commitc368b4e5385a1a81d2429fb32f4234962ef9df02 (patch)
tree604ad12199ef91e559c05bad64eaafda63bb3186 /gnu/packages/crates-web.scm
parentc630294c67f76c0d0a4e4fc28ce37183c41c9f85 (diff)
downloadguix-c368b4e5385a1a81d2429fb32f4234962ef9df02.tar
guix-c368b4e5385a1a81d2429fb32f4234962ef9df02.tar.gz
gnu: rust-warp-0.2: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-warp-0.2): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: Iea234888c25a4711729d5e32d5834470f8d94011
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 7202739edb..e92b807f57 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3396,6 +3396,48 @@ the Trust-DNS client to use rustls for TLS.")
(("rust-openssl" ,rust-openssl-0.10)
("rust-tokio" ,rust-tokio-0.1))))))
+(define-public rust-warp-0.2
+ (package
+ (name "rust-warp")
+ (version "0.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "warp" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "01wl8kv5hh1dd7gcwdrmn9xfs7jjsh9yc8xa06ph8yf9akgyc6zl"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-async-compression" ,rust-async-compression-0.3)
+ ("rust-bytes" ,rust-bytes-0.5)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-headers" ,rust-headers-0.3)
+ ("rust-http" ,rust-http-0.2)
+ ("rust-hyper" ,rust-hyper-0.13)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-mime" ,rust-mime-0.3)
+ ("rust-mime-guess" ,rust-mime-guess-2)
+ ("rust-multipart" ,rust-multipart-0.17)
+ ("rust-pin-project" ,rust-pin-project-0.4)
+ ("rust-scoped-tls" ,rust-scoped-tls-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-serde-urlencoded" ,rust-serde-urlencoded-0.6)
+ ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-tokio-rustls" ,rust-tokio-rustls-0.14)
+ ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.11)
+ ("rust-tower-service" ,rust-tower-service-0.3)
+ ("rust-tracing" ,rust-tracing-0.1)
+ ("rust-tracing-futures" ,rust-tracing-futures-0.2)
+ ("rust-urlencoding" ,rust-urlencoding-1))))
+ (home-page "https://github.com/seanmonstar/warp")
+ (synopsis "Composable web server framework")
+ (description "Warp is a composable, web server framework.")
+ (license license:expat)))
+
(define-public rust-web-view-0.7
(package
(name "rust-web-view")