aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-24 10:50:28 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:30 +0200
commit4f95fd68dd6b20373a03366a388aad5fe4a24972 (patch)
tree114c4dc2c5072141318a63e80e2c2dd2f78fd614 /gnu/packages/crates-web.scm
parent80fca36e8ec5036628367c777eb962bb85df2cc4 (diff)
downloadguix-4f95fd68dd6b20373a03366a388aad5fe4a24972.tar
guix-4f95fd68dd6b20373a03366a388aad5fe4a24972.tar.gz
gnu: rust-httparse-1: Move to (gnu packages crates-web).
* gnu/packages/crates-io.scm (rust-httparse-1): Move from here ... * gnu/packages/crates-web.scm: ... to here. Change-Id: I941a397f506a25179e74167a3e4c463a342e935b
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index b921598f8a..313294f67d 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -2087,6 +2087,26 @@ HTTP request or response body.")
"This package provides a tiny, safe, speedy, zero-copy HTTP/1.x parser.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-httpdate-1
+ (package
+ (name "rust-httpdate")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "httpdate" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1aa9rd2sac0zhjqh24c9xvir96g188zldkx0hr6dnnlx5904cfyz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.5))))
+ (home-page "https://github.com/pyfisch/httpdate")
+ (synopsis "HTTP date parsing and formatting")
+ (description
+ "This crates parses and formats HTTP datetime strings.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hyper-0.14
(package
(name "rust-hyper")