aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 11:18:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:13 +0200
commit3427ea37b08366e3b0312a49c636e8c72bc36714 (patch)
tree0432e00b77c79b677d44d24dfa0565573e63c014 /gnu/packages/crates-graphics.scm
parent980190846b8a5f16fdf0b29d528ea35ed3f26463 (diff)
downloadguix-3427ea37b08366e3b0312a49c636e8c72bc36714.tar
guix-3427ea37b08366e3b0312a49c636e8c72bc36714.tar.gz
gnu: Add rust-wayland-cursor-0.31.
* gnu/packages/crates-graphics.scm (rust-wayland-cursor-0.31): New variable. (rust-wayland-cursor-0.30): Inherit from rust-wayland-cursor-0.31. Change-Id: I02450b25bbad32e23bceee0f8878283cd1f14acb
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm35
1 files changed, 26 insertions, 9 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 9d48980344..33bcc81d65 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -3746,25 +3746,22 @@ and wayland-server.")
(("rust-nix" ,rust-nix-0.14)
("rust-wayland-sys" ,rust-wayland-sys-0.21))))))
-(define-public rust-wayland-cursor-0.29
+(define-public rust-wayland-cursor-0.31
(package
(name "rust-wayland-cursor")
- (version "0.29.5")
+ (version "0.31.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "wayland-cursor" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0qbn6wqmjibkx3lb3ggbp07iabzgx2zhrm0wxxxjbmhkdyvccrb8"))))
+ (base32 "0nxdyyg3a3649n316fbnm8rak5k90j580kfnfxn9src6x45a4jm4"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
- (("rust-nix" ,rust-nix-0.24)
- ("rust-wayland-client" ,rust-wayland-client-0.29)
- ("rust-xcursor" ,rust-xcursor-0.3))))
- (inputs
- (list rust-nix-0.24 rust-wayland-client-0.29 rust-xcursor-0.3))
+ `(#:cargo-inputs (("rust-nix" ,rust-nix-0.26)
+ ("rust-wayland-client" ,rust-wayland-client-0.31)
+ ("rust-xcursor" ,rust-xcursor-0.3))))
(home-page "https://github.com/smithay/wayland-rs")
(synopsis "Bindings to libwayland-cursor")
(description
@@ -3773,6 +3770,26 @@ and load them into WlBuffers as well as obtain the necessary metadata to
properly display animated cursors.")
(license license:expat)))
+(define-public rust-wayland-cursor-0.29
+ (package
+ (inherit rust-wayland-cursor-0.31)
+ (name "rust-wayland-cursor")
+ (version "0.29.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayland-cursor" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0qbn6wqmjibkx3lb3ggbp07iabzgx2zhrm0wxxxjbmhkdyvccrb8"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-nix" ,rust-nix-0.24)
+ ("rust-wayland-client" ,rust-wayland-client-0.29)
+ ("rust-xcursor" ,rust-xcursor-0.3))))
+ (inputs
+ (list rust-nix-0.24 rust-wayland-client-0.29 rust-xcursor-0.3))))
+
(define-public rust-wayland-cursor-0.28
(package
(inherit rust-wayland-cursor-0.29)