aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 19:44:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:03 +0200
commit639ea4873149103c451fef03f1edbb24c3b96cf0 (patch)
tree349671d999ac57fb492ecaeeb11ba4499107b24e /gnu/packages/crates-crypto.scm
parent1f4c5d496f406b79d3ac28604bfae372a5a9710c (diff)
downloadguix-639ea4873149103c451fef03f1edbb24c3b96cf0.tar
guix-639ea4873149103c451fef03f1edbb24c3b96cf0.tar.gz
gnu: rust-ctr: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-ctr-0.9, rust-ctr-0.8, rust-ctr-0.6): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: I34938901cac417eace8be453465ba56a7a338f24
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm63
1 files changed, 63 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 5a43157839..24154605bf 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1646,6 +1646,69 @@ algorithms.")
hash functions.")
(license license:expat)))
+(define-public rust-ctr-0.9
+ (package
+ (name "rust-ctr")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ctr" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0d88b73waamgpfjdml78icxz45d95q7vi2aqa604b0visqdfws83"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cipher" ,rust-cipher-0.4))
+ #:cargo-development-inputs
+ (("rust-aes" ,rust-aes-0.8)
+ ("rust-cipher" ,rust-cipher-0.4)
+ ("rust-hex-literal" ,rust-hex-literal-0.3)
+ ("rust-kuznyechik" ,rust-kuznyechik-0.8)
+ ("rust-magma" ,rust-magma-0.8))))
+ (home-page "https://docs.rs/ctr/")
+ (synopsis "CTR block mode of operation")
+ (description "This package provides a generic implementations of CTR mode
+for block ciphers. Mode functionality is accessed using traits from
+re-exported cipher crate.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-ctr-0.8
+ (package
+ (inherit rust-ctr-0.9)
+ (name "rust-ctr")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ctr" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1sk1aykwhkny92cnvl6s75dx3fyvfzw5xkd6xz3y7w5anhgvk6q4"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-cipher" ,rust-cipher-0.3))))))
+
+(define-public rust-ctr-0.6
+ (package
+ (inherit rust-ctr-0.8)
+ (name "rust-ctr")
+ (version "0.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ctr" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0zvyf13675hrlc37myj97k5ng7m1mj3d9p4ic4yvyhvl9zak0jpv"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-cipher" ,rust-cipher-0.2))))))
+
(define-public rust-curve25519-dalek-3
(package
(name "rust-curve25519-dalek")