aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-09 21:32:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-09 22:05:24 +0100
commit1bbf632574dc47db680e883beb0d6a997fc867e6 (patch)
treecf6cabb88e8f9de6b757e7c7c4f1f19b4af0a29a /gnu/packages/cran.scm
parentc341a4d02e9e63856bd763f8aba016767abb30ae (diff)
downloadguix-1bbf632574dc47db680e883beb0d6a997fc867e6.tar
guix-1bbf632574dc47db680e883beb0d6a997fc867e6.tar.gz
gnu: Add r-ggtext.
* gnu/packages/cran.scm (r-ggtext): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bb5fea95b8..232cea5cbc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16778,6 +16778,33 @@ inline CSS directives, and it can be rendered both with and without word
wrap.")
(license license:expat)))
+(define-public r-ggtext
+ (package
+ (name "r-ggtext")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggtext" version))
+ (sha256
+ (base32
+ "0n19dlcys8v7myfyckr6dnq0kx79k3sbh8nwx1jsx8pgzfbi8a2b"))))
+ (properties `((upstream-name . "ggtext")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridtext" ,r-gridtext)
+ ("r-rlang" ,r-rlang)
+ ("r-scales" ,r-scales)))
+ (native-inputs `(("r-knitr" ,r-knitr)))
+ (home-page "https://wilkelab.org/ggtext/")
+ (synopsis "Improved text rendering support for ggplot2")
+ (description
+ "This package provides a ggplot2 extension that enables the rendering of
+complex formatted plot labels (titles, subtitles, facet labels, axis labels,
+etc.). Text boxes with automatic word wrap are also supported.")
+ (license license:gpl2)))
+
;; This package includes minified JavaScript files. When upgrading please
;; check that there are no new minified JavaScript files.
(define-public r-flexdashboard