aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-09 16:27:57 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-03-10 11:07:24 +0800
commitb05bb6608c7f25ddce6b563194ba5a3007009282 (patch)
tree1479dd64865bf73c84ec4e1b6b1719d517b9cadb /gnu/packages/cpp.scm
parent7f1cd8847fb3c7a1c75df0a06e1fa4d298a66cbb (diff)
downloadguix-b05bb6608c7f25ddce6b563194ba5a3007009282.tar
guix-b05bb6608c7f25ddce6b563194ba5a3007009282.tar.gz
gnu: gperftools: Fix build on riscv64-linux.
* gnu/packages/cpp.scm(gperftools)[arguments]: When building for riscv64-linux always link with libatomic. Change-Id: I067087fffd8c142759b6d113f993c3e2ab1aef9b Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3b65ce9f4a..d451eea2fd 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -30,7 +30,7 @@
;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2022, 2023, 2024 David Elsing <david.elsing@posteo.net>
-;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022-2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
@@ -907,9 +907,12 @@ lock-free fixed size queue written in C++11.")
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- ;; The tests are flaky when run in parallel. For more info:
- ;; https://bugs.gnu.org/46562
- '(#:parallel-tests? #f))
+ ;; The tests are flaky when run in parallel. For more info:
+ ;; https://bugs.gnu.org/46562
+ `(#:parallel-tests? #f
+ ,@(if (target-riscv64?)
+ `(#:make-flags (list "LDFLAGS=-latomic"))
+ '())))
(native-inputs
(list autoconf automake libtool
;; For tests.