aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-09-20 14:39:31 +0200
committerLudovic Courtès <ludo@gnu.org>2023-09-28 11:44:10 +0200
commit700e4e8a42904b479a0cecaca51f634888f5d893 (patch)
tree752b1c07e84549e64415421ccade2698a05454c4 /gnu/packages/cpp.scm
parent94165cea0829d6b3e9ab1180d6ea1ba0b0c9b430 (diff)
downloadguix-700e4e8a42904b479a0cecaca51f634888f5d893.tar
guix-700e4e8a42904b479a0cecaca51f634888f5d893.tar.gz
gnu: Add robin-hood-hashing.
* gnu/packages/cpp.scm (robin-hood-hashing): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4ee7f375d7..7117ada000 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -223,6 +224,34 @@ range-v3 ranges are an abstraction layer on top of iterators.")
;; Others
license:boost1.0))))
+(define-public robin-hood-hashing
+ (package
+ (name "robin-hood-hashing")
+ (version "3.11.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/martinus/robin-hood-hashing")
+ (commit version)))
+ (modules '((guix build utils)))
+ (snippet #~(delete-file-recursively "src/test/thirdparty"))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qx6i09sp8c3l89mhyaql144nzh2h26ky9ms3n5l85qplx1vv2r7"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f ;; Needs bundled libraries for tests.
+ ;; By default this option is set to ON and removes the ability to
+ ;; install the library.
+ #:configure-flags
+ #~(list "-DRH_STANDALONE_PROJECT=OFF")))
+ (home-page "https://github.com/martinus/robin-hood-hashing")
+ (synopsis "Unordered set and map data structures library")
+ (description "This library provides a header-only unordered set and map
+data structures for C++.")
+ (license license:expat)))
+
(define-public c++-gsl
(package
(name "c++-gsl")