aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-09-01 20:44:55 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-01 10:53:37 -0400
commit5f00e0363c194cd1f52eeb8da2417325af7c5acb (patch)
tree8d3b5b1dac2f59b5bdb2dfe837702c16c228c376 /gnu/packages/cpp.scm
parent2e568050d7dab28879f97e6e9078f7bca3073732 (diff)
downloadguix-5f00e0363c194cd1f52eeb8da2417325af7c5acb.tar
guix-5f00e0363c194cd1f52eeb8da2417325af7c5acb.tar.gz
gnu: Add libcppgenerate.
* gnu/packages/cpp.scm (libcppgenerate): New variable. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 2f8cc2ce25..11777340ef 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1731,6 +1731,30 @@ C. It focuses on standardization and parsing exactness and is at ease with
almost every type of file containing key/value pairs.")
(license license:gpl3+)))
+(define-public libcppgenerate
+ ;; dbus-cxx requires an unreleased fix.
+ (let ((commit "930c5503f76c877b72b9ff8546353d6f422bd010")
+ (revision "0"))
+ (package
+ (name "libcppgenerate")
+ (version (git-version "0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rm5248/libcppgenerate")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0csdg9b406i85aqgivjmvqjdnqbyiyjh3s0xsfsxppv7wlh7j85r"))))
+ (build-system cmake-build-system)
+ (arguments (list #:configure-flags #~'("-DENABLE_TESTS=ON")))
+ (home-page "https://github.com/rm5248/libcppgenerate")
+ (synopsis "C++ code generator library for C++")
+ (description "@code{libcppgenerate} is a library for generating C++ code
+from C++.")
+ (license license:asl2.0))))
+
(define-public libcutl
(package
(name "libcutl")