aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2024-07-13 18:01:11 +0200
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-15 21:22:12 +0800
commit1cd1caceedb55ed9f7071ca3f0a15930f563f9c2 (patch)
tree12e95fa277b4987630bf390f2ab1c51e0aaadb49 /gnu/packages/cpp.scm
parenteb508e32d2d359c94d2cabebfe90dc32ca5dcf4f (diff)
downloadguix-1cd1caceedb55ed9f7071ca3f0a15930f563f9c2.tar
guix-1cd1caceedb55ed9f7071ca3f0a15930f563f9c2.tar.gz
gnu: c2ffi: Update to 18.1.0.0.
Change-Id: Ie4a2c35d001a1c74be117312deb5f81d66109dfd Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 40181358ba..ee945fcc68 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -314,23 +314,21 @@ use by the C++ Core Guidelines maintained by the Standard C++ Foundation.")
(name "c2ffi")
;; As per the c2ffi README: the first three elements are encoding the
;; required Clang/LLVM version, and the last one is the c2ffi revision.
- (version "16.0.0.0")
+ (version "18.1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/rpav/c2ffi")
- ;; Upstream is not tagging releases consistently.
- ;; (commit (string-append "v" version))
- (commit "097cbe61ca02dc79ea60859aa056975131a9d985")))
+ (commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1mqhw4838chl495gaj9z0731ahkmqb4f3wlc1qalk82fdsaniyd5"))
+ (base32 "03hw650wjrc4jb4ra8bwc4rnprr0fpnf3wlxzacfjysvl25jb0j6"))
(modules '((guix build utils)))
(snippet
'(substitute* "CMakeLists.txt"
;; Guix seems to be packaging LLVM libs separately thus -lLLVM
- ;; won't work, every used library must be specified explicitly.
+ ;; won't work. Instead every library used must be listed.
(("c2ffi PUBLIC clang-cpp LLVM")
"c2ffi PUBLIC clang-cpp LLVMCore LLVMSupport LLVMMCParser \
LLVMOption LLVMBitReader LLVMProfileData")))))
@@ -346,9 +344,9 @@ LLVMOption LLVMBitReader LLVMProfileData")))))
(when tests?
(invoke "./bin/c2ffi" "--help")))))))
(native-inputs
- (list clang-16)) ; CMakeLists.txt invokes `clang -print-resource-dir`
+ (list clang-18)) ; CMakeLists.txt invokes `clang -print-resource-dir`
(inputs
- (list clang-16)) ; Compiled with gcc, but links against libclang-cpp.so
+ (list clang-18)) ; Compiled with gcc, but links against libclang-cpp.so
(home-page "https://github.com/rpav/c2ffi")
(synopsis "Clang-based FFI wrapper generator")
(description