aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2023-06-25 10:03:57 +0000
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-01 11:53:20 +0200
commit1a86c362a1d5c46ce3cc374daf185140ce8cc9f3 (patch)
tree2252bc9608d58f3a9c6f94ad120557c1f16ca441 /gnu/packages/cpp.scm
parent25045bec6745237fb4e738aa7bafb58b95cd9599 (diff)
downloadguix-1a86c362a1d5c46ce3cc374daf185140ce8cc9f3.tar
guix-1a86c362a1d5c46ce3cc374daf185140ce8cc9f3.tar.gz
gnu: Add tl-optional.
* gnu/packages/cpp.scm (tl-optional): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 139a2b92e0..7d3db8ea9b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2696,3 +2696,36 @@ a hash set which preserve the order of insertion. It is intended for
efficient ordered insertions and lookup, while sacrifing performance for
ordered erase operations.")
(license license:expat)))
+
+(define-public tl-optional
+ (package
+ (name "tl-optional")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/TartanLlama/optional")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qkjplmhilbi1iqxx3pz0grcx5355ymk6wwd4h4309mk156xgx2q"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-cmake-test
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("FetchContent_Declare.*") "")
+ ((".*http.*catchorg/Catch2.*") "")
+ (("FetchContent_MakeAvailable\\(Catch2\\)")
+ "find_package(Catch2 REQUIRED)")))))))
+ (native-inputs (list catch2))
+ (home-page "https://github.com/TartanLlama/optional")
+ (synopsis "Implementation of std::optional with extensions for C++11/14/17")
+ (description "@code{tl::optional} provides a single-header implementation of
+the std::optional for C++11/14/17, with support for monadic operations added in
+C++23.")
+ (license license:cc0)))