aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 11:11:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-13 05:42:58 +0100
commitaaa2add87111051b01159aa2e46dd7f55b28edb6 (patch)
tree8a21ce3863fa8cda0611ea14d007b7f4a64206f2 /gnu/packages/coq.scm
parent8b9b2210dc1a7e1ac63bd85df9e8d0c39c59a3f0 (diff)
downloadguix-aaa2add87111051b01159aa2e46dd7f55b28edb6.tar
guix-aaa2add87111051b01159aa2e46dd7f55b28edb6.tar.gz
gnu: coq-mathcomp: Don't use unstable tarball.
* gnu/packages/coq.scm (coq-mathcomp)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm18
1 files changed, 10 insertions, 8 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 6cedb8363f..fa02f85cdf 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -285,20 +285,22 @@ assistant.")
(package
(name "coq-mathcomp")
(version "1.7.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/math-comp/math-comp/archive/mathcomp-"
- version ".tar.gz"))
- (sha256
- (base32
- "05zgyi4wmasi1rcyn5jq42w0bi9713q9m8dl1fdgl66nmacixh39"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/math-comp/math-comp.git")
+ (commit (string-append "mathcomp-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cdzi67jj440xkdpxm10aly80zpn56vjzj2ygb67iq3xpljlv95h"))))
(build-system gnu-build-system)
(native-inputs
`(("ocaml" ,ocaml)
("which" ,which)
("coq" ,coq)))
(arguments
- `(#:tests? #f; No need to test formally-verified programs :)
+ `(#:tests? #f ; no need to test formally-verified programs :)
#:phases
(modify-phases %standard-phases
(delete 'configure)