aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorJean SIMARD <woshilapin@tuziwo.info>2024-10-18 21:27:37 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-23 12:57:59 +0200
commitb3092b8064a8b3037f8b96c0de4817506cb417a7 (patch)
treecc96ac92635fc1e7dd0a02ec1c9c0acf430e0f28 /gnu/packages/containers.scm
parent8e51e0df31ddfe207496e6d676c9e23ba00251de (diff)
downloadguix-b3092b8064a8b3037f8b96c0de4817506cb417a7.tar
guix-b3092b8064a8b3037f8b96c0de4817506cb417a7.tar.gz
gnu: podman-compose: Update to 1.2.0.
* gnu/packages/containers.scm (podman-compose): Update to 1.2.0. [native-inputs]: Add python-parameterized. Change-Id: I7303d127de02bd8a7d463ee5ba5c08563093e44f Reviewed-by: Tomas Volf <~@wolfsden.cz> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 891e7339e7..3e0cc93d4c 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -578,7 +578,7 @@ To get @code{podman machine} working, install @code{qemu-minimal}, and
(define-public podman-compose
(package
(name "podman-compose")
- (version "1.0.6")
+ (version "1.2.0")
(source
(origin
(method git-fetch)
@@ -587,18 +587,17 @@ To get @code{podman machine} working, install @code{qemu-minimal}, and
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11dwpifkm20vyi6r3fgmiiqc01mpm4r8l0p5gfh0bawi2gklrhsf"))))
+ (base32 "06vm088q1x7j929n93ylq3bav716bqh6l79agj8sgzsqxjsmli73"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags #~(list "pytests")))
- (native-inputs
- (list python-pytest))
- (propagated-inputs
- (list python-dotenv python-pyyaml))
+ (native-inputs (list python-pytest python-parameterized))
+ (propagated-inputs (list python-dotenv python-pyyaml))
(home-page "https://github.com/containers/podman-compose")
(synopsis "Script to run docker-compose.yml using podman")
- (description "This package provides an implementation of
+ (description
+ "This package provides an implementation of
@url{https://compose-spec.io/, Compose Spec} for @code{podman} focused on
being rootless and not requiring any daemon to be running.")
(license license:gpl2)))