aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/containers.scm
diff options
context:
space:
mode:
authorTomas Volf <~@wolfsden.cz>2024-02-13 10:48:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-14 15:27:12 +0000
commit6002e9e7711136373de5a6325769e9c7d11032c9 (patch)
treef5c5689db53119b70b93c12acddb55caba46223a /gnu/packages/containers.scm
parent0c3ae6dc84fa7d12020983a42802346638be66bc (diff)
downloadguix-6002e9e7711136373de5a6325769e9c7d11032c9.tar
guix-6002e9e7711136373de5a6325769e9c7d11032c9.tar.gz
gnu: crun: Update to 1.14.1.
Since upstream does provide properly packaged source archives, the fetch method was switched from git to url. * gnu/packages/containers.scm (crun): Update to 1.14.1. Change-Id: I566d8742b1a3db75aefaa51032e09130a8307a61 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/containers.scm')
-rw-r--r--gnu/packages/containers.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index aef4d0ed03..c321448439 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2023 Zongyuan Li <zongyuan.li@c0x0o.me>
;;; Copyright © 2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,20 +54,20 @@
#:use-module (gnu packages wget))
(define-public crun
- (let ((commit "c381048530aa750495cf502ddb7181f2ded5b400"))
+ (let ((commit "de537a7965bfbe9992e2cfae0baeb56a08128171"))
(package
(name "crun")
- (version "1.4.5")
+ (version "1.14.1")
(source
(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/containers/crun")
- (commit commit)
- (recursive? #t)))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/containers/crun/releases/download/"
+ version
+ "/crun-" version ".tar.gz"))
(sha256
- (base32 "0x2xmr5sv9ivvcv5fl5jjk4kq9b3n97s5hsqiqfwl4rz8qcz4xk1"))
- (file-name (git-file-name name version))))
+ (base32
+ "02lplc2asyllb58mvy7l8b9gsk7fxs95g928xk28yzmf592ay33x"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-systemd")