aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
commite90e0fad1b3ba79d81f02424e143ee6f4f736e8b (patch)
tree2c26190fd9114199b0ef79303e18a61100cab4af /gnu/packages/compression.scm
parent8ea0700d231a8819fc7e8332e9685f0ce15c174e (diff)
parent9ec2a4d3fec44f08a55df9f5f3d1a04b83e7fcf6 (diff)
downloadguix-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar
guix-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 81e95c70e5..4e6a248e8e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -945,7 +945,7 @@ well as bzip2.")
(define-public snappy
(package
(name "snappy")
- (version "1.1.3")
+ (version "1.1.4")
(source (origin
(method url-fetch)
(uri (string-append
@@ -953,7 +953,7 @@ well as bzip2.")
version "/" name "-" version ".tar.gz"))
(sha256
(base32
- "1wzf8yif5ym2gj52db6v5m1pxnmn258i38x7llk9x346y2nq47ig"))))
+ "0mq0nz8gbi1sp3y6xcg0a6wbvnd6gc717f3vh2xrjmfj5w9gwjqk"))))
(build-system gnu-build-system)
(home-page "https://github.com/google/snappy")
(synopsis "Fast compressor/decompressor")
@@ -1128,3 +1128,21 @@ or junctions, and always follows hard links.")
;; libzpaq.cpp contains a mix of public-domain and
;; expat-licenced (or ‘MIT’) code.
license:expat))))
+
+(define-public unrar
+ (package
+ (name "unrar")
+ (version "0.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.gna.org/unrar/unrar-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fgmjaxffj3shyxgy765jhxwz1cq88hk0fih1bsdzyvymyyz6mz7"))))
+ (build-system gnu-build-system)
+ (home-page "http://download.gna.org/unrar")
+ (synopsis "RAR archive extraction tool")
+ (description "Unrar is a simple command-line program to list and extract
+RAR archives.")
+ (license license:gpl2+)))