aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-02-01 10:36:02 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-02-05 06:56:42 +0100
commitc3e61c8c1f5ce867408ba7a113882a4b0ad5b2cb (patch)
treec98901a6b6ddc92b1c88e5c896ec41048f7f18c7 /gnu/packages/commencement.scm
parent81f8cfcf0b52b9928793e5cf8d93d551d771206a (diff)
downloadguix-c3e61c8c1f5ce867408ba7a113882a4b0ad5b2cb.tar
guix-c3e61c8c1f5ce867408ba7a113882a4b0ad5b2cb.tar.gz
gnu: Rename 'guile-3.0/fixed' to 'guile-3.0/pinned'.
* gnu/packages/guile.scm: Rename variable 'guile-3.0/fixed' to 'guile-3.0/pinned', add deprecation. * etc/release-manifest.scm (%packages-to-cross-build): Replace 'guile-3.0/fixed' with 'guile-3.0/pinned'. * gnu/packages/autotools.scm (make-autoconf-wrapper)[inputs]: Likewise. * gnu/packages/commencement.scm (guile-final): Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b4566b41cc..7335aedec2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3623,7 +3623,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; This package must be public because other modules refer to it. However,
;; mark it as hidden so that 'fold-packages' ignores it.
(with-boot4 (hidden-package
- (package-with-bootstrap-guile guile-3.0/fixed))))
+ (package-with-bootstrap-guile guile-3.0/pinned))))
(define-public glibc-utf8-locales-final
;; Now that we have GUILE-FINAL, build the UTF-8 locales. They are needed