aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-11-25 16:17:12 +0100
committerLudovic Courtès <ludo@gnu.org>2023-11-25 16:29:25 +0100
commit95ea1277ae2ebd278bdb51a7887f5ba1116fbc64 (patch)
treeaa6ae1822a089c4e9a00d9e6f76b40149ac5518b /gnu/packages/commencement.scm
parent5149bf99ba0238b647733399b1a9cbf7da486634 (diff)
downloadguix-95ea1277ae2ebd278bdb51a7887f5ba1116fbc64.tar
guix-95ea1277ae2ebd278bdb51a7887f5ba1116fbc64.tar.gz
gnu: commencement: Use locales for the right libc version on GNU/Hurd.
Fixes <https://issues.guix.gnu.org/66472>. Until now, we were unconditionally using ‘glibc-utf8-locales’, which targets the glibc version used on Linux (2.35) rather than that used on the Hurd (2.37). This would lead to build failures due to the inability to use locale encoding when targeting i586-gnu. * gnu/packages/base.scm (glibc-utf8-locales/hurd): New variable. * gnu/packages/commencement.scm (glibc-utf8-locales-final/hurd): New variable. (%boot5-inputs): Use it when ‘target-hurd?’ returns #t. (%final-inputs): Likewise. Change-Id: I1666d615dffbe3561cf2d9612b85cd31a48a7dcd
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 80fdb5aed7..a1ee015d04 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3365,6 +3365,16 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
`(("glibc" ,glibc-final)
("gzip" ,(with-boot4 gzip))))))
+(define-public glibc-utf8-locales-final/hurd
+ ;; Locales for the libc version used on GNU/Hurd.
+ (package
+ (inherit glibc-utf8-locales/hurd)
+ (properties `((hidden? . #t)
+ ,@(package-properties glibc-utf8-locales/hurd)))
+ (native-inputs
+ `(("glibc" ,glibc-final)
+ ("gzip" ,(with-boot4 gzip))))))
+
(define-public ld-wrapper
;; The final 'ld' wrapper, which uses the final Guile and Binutils.
(make-ld-wrapper "ld-wrapper"
@@ -3383,7 +3393,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
;; Now with UTF-8 locales. Remember that the bootstrap binaries were built
;; with an older libc, which cannot load the new locale format. See
;; <https://lists.gnu.org/archive/html/guix-devel/2015-08/msg00737.html>.
- `(("locales" ,glibc-utf8-locales-final)
+ `(("locales" ,(if (target-hurd?)
+ glibc-utf8-locales-final/hurd
+ glibc-utf8-locales-final))
,@(%boot4-inputs)))
(define with-boot5
@@ -3484,7 +3496,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
("gcc" ,gcc-final)
("libc" ,glibc-final)
("libc:static" ,glibc-final "static")
- ("locales" ,glibc-utf8-locales-final))))))
+ ("locales" ,(if (target-hurd?)
+ glibc-utf8-locales-final/hurd
+ glibc-utf8-locales-final)))))))
(define-public canonical-package
(let ((name->package (mlambda (system)