aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-02-28 17:05:33 +0100
committerLudovic Courtès <ludo@gnu.org>2023-02-28 17:10:40 +0100
commit61efecd33934ce6fd800c9a279691700d1f784ed (patch)
treefd8f50d0d07a21bee262117af35d450e60131aa4 /gnu/packages/commencement.scm
parente8e6dbdd6ac6759eb1da22f176925d50f4eb66e3 (diff)
downloadguix-61efecd33934ce6fd800c9a279691700d1f784ed.tar
guix-61efecd33934ce6fd800c9a279691700d1f784ed.tar.gz
gnu: static-bash-for-glibc: Use gexps.
* gnu/packages/commencement.scm (static-bash-for-glibc)[arguments]: Use gexps.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index e48878248d..a11fa37d60 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2022 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
@@ -2945,14 +2945,14 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
#:guile ,%bootstrap-guile
,@(substitute-keyword-arguments (package-arguments static-bash)
- ((#:configure-flags flags '())
+ ((#:configure-flags flags #~'())
;; Add a '-L' flag so that the pseudo-cross-ld of
;; BINUTILS-BOOT0 can find libc.a.
- `(append ,flags
- (list (string-append "LDFLAGS=-static -L"
- (assoc-ref %build-inputs
- "libc:static")
- "/lib")))))))))
+ #~(append #$flags
+ (list (string-append "LDFLAGS=-static -L"
+ (assoc-ref %build-inputs
+ "libc:static")
+ "/lib")))))))))
(define gettext-boot0
;; A minimal gettext used during bootstrap.