aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:51:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-04-10 16:51:24 +0300
commit5b125c31efd8d501b1d96086b8365e7faa4c3f05 (patch)
tree3314c6cd1c2d13b043be9577ae6251af9a7fe339 /gnu/packages/commencement.scm
parent1be53ad1979a1c1da074d260adf376475250dc13 (diff)
downloadguix-5b125c31efd8d501b1d96086b8365e7faa4c3f05.tar
guix-5b125c31efd8d501b1d96086b8365e7faa4c3f05.tar.gz
gnu: Add gdc-toolchain-11.
* gnu/packages/commencement.scm (gdc-toolchain-11): New variable.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 24cffc4252..25e96b1aa6 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3532,6 +3532,14 @@ D lang development to be installed in user profiles. This includes
gdc, as well as libc (headers and binaries, plus debugging symbols
in the @code{debug} output), and binutils.")))
+(define-public gdc-toolchain-11
+ (package (inherit (make-gcc-toolchain gdc-11))
+ (synopsis "Complete GCC tool chain for D lang development")
+ (description "This package provides a complete GCC tool chain for
+D lang development to be installed in user profiles. This includes
+gdc, as well as libc (headers and binaries, plus debugging symbols
+in the @code{debug} output), and binutils.")))
+
;; Provide the Fortran toolchain package only for the version of gfortran that
;; is used by Guix internally to build Fortran libraries, because combining
;; code compiled with different versions can cause problems.