aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cmake.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-27 21:38:53 +0200
committerMarius Bakke <marius@gnu.org>2022-06-27 23:48:00 +0200
commit6cd881401112b1dae524aeb200283e07a7a26c68 (patch)
treecad7f59d5b904794135c73956d3a5f970ab52b91 /gnu/packages/cmake.scm
parent02f7c56ec43b6de5be6195857ab6cbc4f1662190 (diff)
downloadguix-6cd881401112b1dae524aeb200283e07a7a26c68.tar
guix-6cd881401112b1dae524aeb200283e07a7a26c68.tar.gz
gnu: CMake: Remove input labels.
* gnu/packages/cmake.scm (cmake-bootstrap)[inputs]: Remove labels. (cmake)[native-inputs]: Likewise. Use MODIFY-INPUTS.
Diffstat (limited to 'gnu/packages/cmake.scm')
-rw-r--r--gnu/packages/cmake.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index b581217685..4fb74a7c51 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -213,17 +213,18 @@ using the CMake build system.")
(lambda* (#:key (configure-flags '()) #:allow-other-keys)
(apply invoke "./configure" configure-flags))))))
(inputs
- `(("bzip2" ,bzip2)
- ("curl" ,curl)
- ("expat" ,expat)
- ("file" ,file)
- ("jsoncpp" ,jsoncpp)
- ("libarchive" ,libarchive)
- ,@(if (hurd-target?)
- '()
- `(("libuv" ,libuv))) ;not supported on the Hurd
- ("rhash" ,rhash)
- ("zlib" ,zlib)))
+ (append
+ (if (hurd-target?)
+ '()
+ (list libuv)) ;not supported on the Hurd
+ (list bzip2
+ curl
+ expat
+ file
+ jsoncpp
+ libarchive
+ rhash
+ zlib)))
(native-search-paths
(list (search-path-specification
(variable "CMAKE_PREFIX_PATH")
@@ -369,9 +370,8 @@ and workspaces that can be used in the compiler environment of your choice.")
)))
;; Extra inputs required to build the documentation.
(native-inputs
- `(,@(package-native-inputs cmake-minimal)
- ("python-sphinx" ,python-sphinx)
- ("texinfo" ,texinfo)))
+ (modify-inputs (package-native-inputs cmake-minimal)
+ (append python-sphinx texinfo)))
(outputs '("out" "doc"))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))