aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorTim Johann <t1m@phrogstar.de>2023-03-24 21:09:52 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-26 23:24:23 +0200
commitb4fbeae3d90a5d0f8146441772436df2eb471491 (patch)
treeb8032352c781d934c3b19b39f75afb5f352eee88 /gnu/packages/chez.scm
parent547965aa27b6a09cadf42130b7ec7db3f1aee61f (diff)
downloadguix-b4fbeae3d90a5d0f8146441772436df2eb471491.tar
guix-b4fbeae3d90a5d0f8146441772436df2eb471491.tar.gz
gnu: chez-scheme-for-racket-bootstrap-bootfiles: change for aarch64.
* gnu/packages/chez.scm (chez-scheme-for-racket-bootstrap-bootfiles): Temporary change for build on aarch64, making racket available on aarch64. Architecture autodetect in rktboot only addresses x86 archs, so far. This work-around sets the architecture, looked up in translation table, explicitly. The long term solution should be to fix rktboot to include other natively supported architectures in the autodetect mechanism. cf. https://github.com/racket/racket/issues/3948 [arguments] use --machine even when architecture is supported by Racket's fork of ChezScheme. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c6420a980e..ab6eaba6bd 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -692,10 +692,12 @@ source.")))
(search-input-file (or native-inputs inputs)
"/opt/racket-vm/bin/racket")
"../rktboot/main.rkt"
- #$@(if (racket-cs-native-supported-system?)
- #~()
- (let ((m (nix-system->pbarch-machine-type)))
- #~("--machine" #$m)))))))))))))
+ ;; Temporary handling of builds on non-x86 architectures,
+ ;; see https://github.com/racket/racket/issues/3948
+ ;; Autodetect in rktboot only addresses x86 archs, so far.
+ #$@(let ((m (or (racket-cs-native-supported-system?)
+ (nix-system->pbarch-machine-type))))
+ #~("--machine" #$m))))))))))))
(supported-systems
(package-supported-systems chez-scheme-for-racket))
(home-page "https://github.com/racket/ChezScheme")