aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2023-02-03 20:14:12 -0500
committerLudovic Courtès <ludo@gnu.org>2023-02-11 00:09:40 +0100
commita89aa4523befd8c30d9f13800b4833abbc911ba1 (patch)
treefd1f0c52d1450e08678fbb975806a2bbb51b31e3 /gnu/packages/chez.scm
parentfb2bf136f0e27b2b6fd48fb3bb38c121f81af7f9 (diff)
downloadguix-a89aa4523befd8c30d9f13800b4833abbc911ba1.tar
guix-a89aa4523befd8c30d9f13800b4833abbc911ba1.tar.gz
utils: Add target-little-endian?.
* guix/utils.scm (target-little-endian?): New function. * guix/build-system/meson.scm (make-machine-alist): Use it. * gnu/packages/chez.scm (nix-system->pbarch-machine-type): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 0d22e2e20f..1f178d2c72 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Brendan Tildesley <mail@brendan.scot>
-;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021, 2022, 2023 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -251,10 +251,9 @@ provided and is #f."
(if (target-64bit? system)
"64"
"32")
- ;; missing (guix utils) predicate target-little-endian?
- (if (target-ppc32? system)
- "b"
- "l")))
+ (if (target-little-endian? system)
+ "l"
+ "b")))
(define* (racket-cs-native-supported-system? #:optional
(system