aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chemistry.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/chemistry.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/chemistry.scm')
-rw-r--r--gnu/packages/chemistry.scm92
1 files changed, 41 insertions, 51 deletions
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 61b213cd1f..94803719ac 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -70,20 +70,20 @@
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
- `(("eigen" ,eigen)
- ("mmtf-cpp" ,mmtf-cpp)
- ("msgpack" ,msgpack)
- ("googletest" ,googletest)
- ("pkg-config" ,pkg-config)
- ("pybind11" ,pybind11)))
+ (list eigen
+ mmtf-cpp
+ msgpack
+ googletest
+ pkg-config
+ pybind11))
(inputs
- `(("glew" ,glew)
- ("libarchive" ,libarchive)
- ("libmsym" ,libmsym)
- ("molequeue" ,molequeue)
- ("python" ,python)
- ("spglib" ,spglib)
- ("qtbase" ,qtbase-5)))
+ (list glew
+ libarchive
+ libmsym
+ molequeue
+ python
+ spglib
+ qtbase-5))
(arguments
'(#:configure-flags (list "-DENABLE_TESTING=ON"
(string-append "-DSPGLIB_INCLUDE_DIR="
@@ -113,13 +113,9 @@ bioinformatics, materials science, and related areas.")
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
- `(("eigen" ,eigen)
- ("pkg-config" ,pkg-config)))
+ (list eigen pkg-config))
(inputs
- `(("avogadrolibs" ,avogadrolibs)
- ("hdf5" ,hdf5)
- ("molequeue" ,molequeue)
- ("qtbase" ,qtbase-5)))
+ (list avogadrolibs hdf5 molequeue qtbase-5))
;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
(arguments
'(#:tests? #f))
@@ -147,7 +143,7 @@ powerful plugin architecture.")
"1z26lsyf7xwnzwjvimmbla7ckipx6p734w7y0jk2a2fzci8fkdcr"))))
(build-system python-build-system)
(inputs
- `(("python-mmtk" ,python2-mmtk)))
+ (list python2-mmtk))
(arguments
`(#:python ,python-2
;; No test suite
@@ -303,7 +299,7 @@ biological structures.")
"1w1fgxzqrb5yxvpmnc3c9ymnvixy0z1nfafkd9whg9zw8nbgl998"))))
(build-system cmake-build-system)
(inputs
- `(("qtbase" ,qtbase-5)))
+ (list qtbase-5))
(arguments
'(#:configure-flags '("-DENABLE_TESTING=ON")
#:phases
@@ -355,12 +351,10 @@ staged, and output files collected using a standard interface.")
"016h4bqg419p6s7bcx55q5iik91gqmk26hbnfgj2j6zl0j36w51r"))))
(build-system python-build-system)
(inputs
- `(("python-matplotlib" ,(with-numpy-1.8 python2-matplotlib))
- ("python-scientific" ,python2-scientific)
- ("netcdf" ,netcdf)
- ("gv" ,gv)))
+ (list (with-numpy-1.8 python2-matplotlib) python2-scientific netcdf
+ gv))
(propagated-inputs
- `(("python-mmtk" ,python2-mmtk)))
+ (list python2-mmtk))
(arguments
`(#:python ,python-2
#:tests? #f ; No test suite
@@ -416,7 +410,7 @@ NumPy < 1.9.")
"1apf2n8nb34z09xarj7k4jgriq283l769sakjmj5aalpbilvai4q"))))
(build-system cmake-build-system)
(inputs
- `(("zlib" ,zlib)))
+ (list zlib))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -502,13 +496,13 @@ stored with user-specified precision.")
("python-pygments" ,python-pygments)
("python-sphinx" ,python-sphinx)))
(inputs
- `(("fftwf" ,fftwf)
- ("hwloc" ,hwloc-2 "lib")
- ("lmfit" ,lmfit)
- ("openblas" ,openblas)
- ("perl" ,perl)
- ("tinyxml2" ,tinyxml2)
- ("tng" ,tng)))
+ (list fftwf
+ `(,hwloc-2 "lib")
+ lmfit
+ openblas
+ perl
+ tinyxml2
+ tng))
(home-page "http://www.gromacs.org/")
(synopsis "Molecular dynamics software package")
(description "GROMACS is a versatile package to perform molecular dynamics,
@@ -549,12 +543,9 @@ usual algorithms you expect from a modern molecular dynamics implementation.")
(assoc-ref %build-inputs "inchi") "/include/inchi"))
#:test-target "test"))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("eigen" ,eigen)
- ("inchi" ,inchi)
- ("libxml2" ,libxml2)
- ("zlib" ,zlib)))
+ (list eigen inchi libxml2 zlib))
(home-page "http://openbabel.org/wiki/Main_Page")
(synopsis "Chemistry data manipulation toolbox")
(description
@@ -649,19 +640,18 @@ symmetries written in C. Spglib can be used to:
(string-append "--prefix=" (assoc-ref outputs "out"))
"--root=/"))))))
(inputs
- `(("freetype" ,freetype)
- ("libpng" ,libpng)
- ("freeglut" ,freeglut)
- ("glew" ,glew)
- ("libxml2" ,libxml2)
- ("mmtf-cpp" ,mmtf-cpp)
- ("msgpack" ,msgpack)
- ("python-pyqt" ,python-pyqt)
- ("glm" ,glm)
- ("netcdf" ,netcdf)))
+ (list freetype
+ libpng
+ freeglut
+ glew
+ libxml2
+ mmtf-cpp
+ msgpack
+ python-pyqt
+ glm
+ netcdf))
(native-inputs
- `(("catch2" ,catch-framework2)
- ("python-setuptools" ,python-setuptools)))
+ (list catch-framework2 python-setuptools))
(home-page "https://pymol.org")
(synopsis "Molecular visualization system")
(description "PyMOL is a capable molecular viewer and renderer. It can be