aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-04 10:51:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-04 18:47:17 +0200
commitf234cda89a974fe69354baed5f41919add91bd60 (patch)
tree4d774cb7ead62397456f0944c8898586cdb34929 /gnu/packages/check.scm
parentd60b77ee5d97f54ffd9f6b5998cefa61ff2fd231 (diff)
downloadguix-f234cda89a974fe69354baed5f41919add91bd60.tar
guix-f234cda89a974fe69354baed5f41919add91bd60.tar.gz
gnu: Add python-pytest-mypy-plugins.
* gnu/packages/check.scm (python-pytest-mypy-plugins): New variable.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 17c2b7284e..87728fefa3 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2015, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2020, 2021, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016-2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2017, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
@@ -2465,6 +2465,30 @@ Pytest that runs the mypy static type checker on your source files as part of
a Pytest test execution.")
(license license:expat)))
+(define-public python-pytest-mypy-plugins
+ (package
+ (name "python-pytest-mypy-plugins")
+ (version "1.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-mypy-plugins" version))
+ (sha256
+ (base32
+ "05ng29b05gasqj195i9hyyhx5shmwypyvajb7plxwha3g36qq98z"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (propagated-inputs (list python-chevron
+ python-decorator
+ python-mypy
+ python-pytest
+ python-pyyaml
+ python-regex))
+ (home-page "https://github.com/TypedDjango/pytest-mypy-plugins")
+ (synopsis "Pytest plugin for writing tests for mypy plugins")
+ (description "This package provides a pytest plugin for writing tests for
+mypy plugins.")
+ (license license:expat)))
+
(define-public python-pytest-pep8
(package
(name "python-pytest-pep8")