aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-10-04 11:20:30 +0100
committerMathieu Othacehe <othacehe@gnu.org>2023-10-14 15:31:28 +0200
commite4fb70e2e87d8746d534ed295e79ab1ae3666a47 (patch)
treea47b1b17ca313e0bbc2a70a142c66b9c454a6b86 /gnu/packages/check.scm
parent8e8d20b6b35d3ab529f9045cc8a779cdcec9c471 (diff)
downloadguix-e4fb70e2e87d8746d534ed295e79ab1ae3666a47.tar
guix-e4fb70e2e87d8746d534ed295e79ab1ae3666a47.tar.gz
gnu: guile-proba: Fix environment vars in Guile Proba's script.
* gnu/packages/check.scm (guile-proba): Micro fix. Guile Proba's CLI script, as created via Guix's `wrap-program', should take into account (as opposed to discard) the original, user-defined values of `GUILE_LOAD_PATH' and `GUILE_LOAD_COMPILED_PATH'. Currently, Guile Proba's CLI script is unable to find any third-party library needed by the app being tested. This micro change should fix this. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1e4edd5b6e..cf26196a24 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3599,8 +3599,8 @@ that can be used to verify that future runs produce the same data.")
(copy-file "proba.scm" script)
(chmod script #o555)
(wrap-program script
- `("GUILE_LOAD_PATH" = (,(getenv "GUILE_LOAD_PATH")))
- `("GUILE_LOAD_COMPILED_PATH" =
+ `("GUILE_LOAD_PATH" prefix (,(getenv "GUILE_LOAD_PATH")))
+ `("GUILE_LOAD_COMPILED_PATH" prefix
(,(getenv "GUILE_LOAD_COMPILED_PATH")))))))
(add-after 'install 'install-manual
(lambda* (#:key outputs #:allow-other-keys)