aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-17 09:42:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:17 -0400
commite27acc6fc710014505766566d1676d10030d8fee (patch)
tree7a90f9bf5b773a5b1eb38508ec7db946386a9caa /gnu/packages/check.scm
parent5ae2e2ce9a884879ba24e7e3497d217f7a4ac92b (diff)
downloadguix-e27acc6fc710014505766566d1676d10030d8fee.tar
guix-e27acc6fc710014505766566d1676d10030d8fee.tar.gz
gnu: python-pytest-asyncio: Update to 0.21.0.
* gnu/packages/check.scm (python-pytest-asyncio): Update to 0.21.0. [build-system]: Use pyproject-build-system. [arguments]: Set #:tests? to #f. Remove check phase override. [native-inputs]: Remove now unused python-async-generator, python-flaky, python-hypothesis and python-pytest. [propagated-inputs]: Add python-pytest.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 33bc808687..ac8de96b1c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2031,7 +2031,7 @@ executed.")
(define-public python-pytest-asyncio
(package
(name "python-pytest-asyncio")
- (version "0.17.2")
+ (version "0.21.0")
(source
(origin
(method git-fetch) ;for tests
@@ -2040,24 +2040,18 @@ executed.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0sl0ckc23m40q6r2xcidsizrgqbbsfa7rwmr80fss359xsydf073"))))
- (build-system python-build-system)
+ (base32 "03wljn0gdwyfr5s1795w3h2mfvvi23bn42nwjv5568rgphqyldqq"))))
+ (build-system pyproject-build-system)
(arguments
- (list #:phases
+ (list #:tests? #f ;XXX: to avoid a cycle with python-pytest-trio
+ #:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'pretend-version
(lambda _
(setenv "SETUPTOOLS_SCM_PRETEND_VERSION"
- #$(package-version this-package))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (invoke "pytest" "-vv" "tests"))))))
- (native-inputs
- (list python-async-generator
- python-flaky
- python-hypothesis
- python-pytest
- python-setuptools-scm))
+ #$(package-version this-package)))))))
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-pytest))
(home-page "https://github.com/pytest-dev/pytest-asyncio")
(synopsis "Pytest support for asyncio")
(description "Python asyncio code is usually written in the form of