aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-01-15 23:49:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 21:13:01 +0000
commitc2f5d0f7d8d58aa48b5f83f38e4395b7d22955cd (patch)
tree4dd16529c9a16cb2282f84d0fd6707fd3ada3849 /gnu/packages/check.scm
parent3cf199dbcf85a44fa8370e786e568fc3feb7067c (diff)
downloadguix-c2f5d0f7d8d58aa48b5f83f38e4395b7d22955cd.tar
guix-c2f5d0f7d8d58aa48b5f83f38e4395b7d22955cd.tar.gz
gnu: Add python-pytest-tornado5.
* gnu/packages/check.scm (python-pytest-tornado5): New variable. Change-Id: I9843e91d750bf17128eb6f566b8dbb5cbc0d8278 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index b520d6c58a..5237f93a93 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
+;;; Copyright © 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3503,6 +3504,29 @@ tables by saving expected data in a data directory (courtesy of pytest-datadir)
that can be used to verify that future runs produce the same data.")
(license license:expat)))
+(define-public python-pytest-tornado5
+ (package
+ (name "python-pytest-tornado5")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-tornado5" version))
+ (sha256
+ (base32
+ "0qb62jw2w0xr6y942yp0qxiy755bismjfpnxaxjjm05gy2pymr8d"))))
+ (build-system pyproject-build-system)
+ (arguments
+ ;; Tests require pytest < 6
+ (list #:tests? #f))
+ (propagated-inputs (list python-pytest python-tornado))
+ (home-page "https://github.com/vidartf/pytest-tornado")
+ (synopsis
+ "Fixtures and markers to simplify testing of Tornado applications")
+ (description
+ "This package provides a @code{py.test} plugin supplying fixtures and
+markers to simplify testing of asynchronous tornado applications.")
+ (license license:asl2.0)))
+
(define-public guile-proba
(package
(name "guile-proba")