aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-04-30 23:16:54 +0800
committerMarius Bakke <marius@gnu.org>2023-04-30 23:25:46 +0800
commita34348967e032acfab2aa0b512d318a70f5543dd (patch)
tree9ef3bde4168cc015515c92a6db9f95f564a82bbe /gnu/packages/check.scm
parentf9a60f34670ba36724d3efec0dc266e0d6d0cb00 (diff)
downloadguix-a34348967e032acfab2aa0b512d318a70f5543dd.tar
guix-a34348967e032acfab2aa0b512d318a70f5543dd.tar.gz
gnu: clitest: Fix test failure with newer grep.
* gnu/packages/patches/clitest-grep-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/check.scm (clitest)[source](patches): New field. [arguments]: While at it, remove obsolete substitution.
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e671972654..17c2b7284e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -310,6 +310,7 @@ for C++ 11 and beyond implemented as a single-header library.")
(method git-fetch)
(uri (git-reference (url home-page) (commit version)))
(file-name (git-file-name name version))
+ (patches (search-patches "clitest-grep-compat.patch"))
(sha256
(base32
"1p745mxiq3hgi3ywfljs5sa1psi06awwjxzw0j9c2xx1b09yqv4a"))))
@@ -325,13 +326,6 @@ for C++ 11 and beyond implemented as a single-header library.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (substitute* "test.md"
- ;; One test looks for an error from grep in the form "grep: foo",
- ;; but our grep returns the absolute file name on errors. Adjust
- ;; the test to cope with that.
- (("sed 's/\\^e\\*grep: \\.\\*/")
- "sed 's/.*e*grep: .*/"))
-
(setenv "HOME" "/tmp")
(invoke "./clitest" "test.md"))))
(replace 'install