aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-01 10:11:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-12-02 20:39:27 +0200
commit6897a6a48164768785d09055c7048c2bfc3745c3 (patch)
tree2f0a857563559a3ce12adf595ab6f9d095324432 /gnu/packages/check.scm
parentfc7db2df40840e3020a9f4954f08f744390abf62 (diff)
downloadguix-6897a6a48164768785d09055c7048c2bfc3745c3.tar
guix-6897a6a48164768785d09055c7048c2bfc3745c3.tar.gz
gnu: python-lit: Update to 17.0.6.
* gnu/packages/check.scm (python-lit): Update to 17.0.6. [native-inputs]: Remove llvm-14; add llvm. Change-Id: I45ccc5302c2481b82f26201e66994e15eeaecc9d
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1f5b886977..c295e326c9 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2358,14 +2358,14 @@ programs, something like CSmith, a random generator of C programs.")
(define-public python-lit
(package
(name "python-lit")
- (version "16.0.0")
+ (version "17.0.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "lit" version))
(sha256
(base32
- "04dyv8b2nbdbn61zdgm042a21dwidyapn9zbinlf879a29rc6jiw"))))
+ "06z3p85gsy5hw3rbk0ym8aig9mvry1327gz7dfjhjigwandszafz"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -2374,8 +2374,8 @@ programs, something like CSmith, a random generator of C programs.")
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "python" "lit.py" "tests")))))))
- (native-inputs
- (list llvm-14))
+ ;; This can be built with any version of llvm.
+ (native-inputs (list llvm))
(home-page "https://llvm.org/")
(synopsis "LLVM Software Testing Tool")
(description "@code{lit} is a portable tool for executing LLVM and Clang