aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-19 10:02:15 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-19 10:02:15 +0100
commit1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523 (patch)
tree77cbf407563c8c4b1acc00fe0fdb8ac79b1fdd95 /gnu/packages/check.scm
parentf64ec2b15132c46bcdf0546196646237890832f6 (diff)
parentb7abea0fd6a146563830db1dc4ddd0cceb6fcf1c (diff)
downloadguix-1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523.tar
guix-1cc3b7e80f60a2a5a6a1400ed0b025efeae7a523.tar.gz
Merge branch 'master' into gnome-team
Change-Id: I62da840b7600f2d3d8541e666d09e2f2a1b7d8c4
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm33
1 files changed, 14 insertions, 19 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index cf26196a24..1f5b886977 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2551,7 +2551,7 @@ mypy plugins.")
(define-public python-pytest-perf
(package
(name "python-pytest-perf")
- (version "0.12.0")
+ (version "0.13.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2560,26 +2560,21 @@ mypy plugins.")
(file-name (git-file-name name version))
(sha256
(base32
- "05mgknvrmyz1kmkgw8jzvisavc68wz1g2wxv69i6xvzgqxf17m9f"))))
- (build-system python-build-system)
+ "1hrccvrbccqwba04pqj749hdzn4sgldmbpg74nf3fzz7wyg6jxqk"))))
+ (build-system pyproject-build-system)
(arguments
(list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-k"
- (string-append
- ;; Do not test the myproject.toml build as it tries to pull
- ;; dependencies from the internet.
- "not project "
- ;; The benchmark test attempts to install the
- ;; package, failing to pull its dependencies from the
- ;; network.
- "and not BenchmarkRunner "
- ;; The upstream_url test requires networking.
- "and not upstream_url"))))))))
+ #:test-flags '(list "-k"
+ (string-append
+ ;; Do not test the myproject.toml build as it tries to pull
+ ;; dependencies from the internet.
+ "not project "
+ ;; The benchmark test attempts to install the
+ ;; package, failing to pull its dependencies from the
+ ;; network.
+ "and not BenchmarkRunner "
+ ;; The upstream_url test requires networking.
+ "and not upstream_url"))))
(native-inputs
(list python-pytest
python-pytest-black